Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Public Users Cannot Sign Up - Infinite CAPTCHA Loop Edited

Recently upgraded to JIRA 8.15.0 and whenever public users attempt to create an account, when they click on 'Sign Up', nothing happens and the CAPTCHA resets. Literally, if I test it myself, I can keep clicking on "Sign Up" and the CAPTCHA just refreshes over and over. No errors come up. Does not make a difference if a legitimate email address is filled in along with the correct CAPTCHA code (for example, if I put "test-account@gmail.com" and "arcting" as the CAPTCHA, nothing happens when I click on "Sign Up").

09_MAR_2021_01_12_04_74.PNG

The logs shows this over and over when clicking "Sign Up":

108.162.249.71 1292x18225x1 - [08/Mar/2021:21:32:02 +1100] "POST /servicedesk/customer/user/emailsignup HTTP/1.1" 400 115 15 "https://jira.mysite.com.au:2053/servicedesk/customer/user/signup" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36" "1ofjru8"

108.162.249.71 1292x18226x1 - [08/Mar/2021:21:32:02 +1100] "GET /captcha?ts=60 HTTP/1.1" 200 2579 16 "https://jira.mysite.com.au:2053/servicedesk/customer/user/signup" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36" "1ofjru8"

[REPEAT]

I have plenty of memory free (4 GB), using "Microsoft JDBC Driver 7.2 for SQL Server 7.2.1.0" and JAVA "1.8.0_275".

The address where users are signing up is as followed:

https://jira.mysite.com.au:2053/servicedesk/customer/user/signup

Does anyone have any idea what is going on? Again, I can just keep pressing on "Sign Up" and the site does nothing. It just refreshes the CAPTCHA and that's it. The button should be called "Refresh CAPTCHA and do nothing". It is extremely annoying because no public users can make an account and raise tickets/service desk issues! It's causing a bit of frustration.

Public access is ENABLED. Even if I disable CAPTCHA, it still won't do anything and I can keep clicking on "Sign Up". This was working all fine until I upgraded to 8.15.0. And yes, I have tried using my browser (Google Chrome V88.0.4324.190, Windows 7 32-bit) with a cleared cache and all cookies removed. I have also tried using Mozilla Firefox. Same problem persists.

Video Showing the Problem (Right Click -> Save As)

Thanks.

3 answers

1 accepted

0 votes
Answer accepted

Unbelievable. Changing "Is email verification required for signup?" in "<Your Jira's URL>/secure/admin/SDConfiguration.jspa" from "Yes, customers should verify their emails" to "No, customers can just sign up" seems to have fixed the problem!

No idea how that solved it, but I assume that option is to have users who are already a member of "Jira Software" on the server to register since they would have a verified email in the database which would permit them to proceed. Still, having "Is email verification required for signup?"on is completely broken because the CAPTCHA just keeps refreshing as explained above with no errors, but Atlassian can figure that out if other users report it. Also, in my Virtual Machine, this option was set to "Yes" and I didn't have the same issue. Quite strange. Would be nice if someone could explain why that happens.

For now, I can happily mark this as resolved. I will test it for a few days however to make sure it's working fine for users. If there are any concerns, I will comment back. Thanks for all your help "Dirk R." and to "Mateusz T." as well from Atlassian support. Appreciate it.

No one has literally any idea what's going on?

I tried signing up on m iPhone (via 4G and not from the same network as the server), and this is what I got.

1.129.105.59 1015x1784x1 - [09/Mar/2021:16:55:47 +1100] "POST /rest/analytics/1.0/publish/bulk HTTP/1.1" 200 40 0 "https://jira.mysite.com.au:2053/servicedesk/customer/user/signup" "Mozilla/5.0 (iPhone; CPU iPhone OS 14_4 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/87.0.4280.77 Mobile/15E148 Safari/604.1" "2i9nbo"

1.129.105.59 1015x1785x1 - [09/Mar/2021:16:55:54 +1100] "POST /servicedesk/customer/user/emailsignup HTTP/1.1" 400 93 0 "https://jira.mysite.com.au:2053/servicedesk/customer/user/signup" "Mozilla/5.0 (iPhone; CPU iPhone OS 14_4 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/87.0.4280.77 Mobile/15E148 Safari/604.1" "2i9nbo"

1.129.105.59 1015x1786x1 - [09/Mar/2021:16:55:54 +1100] "GET /captcha?ts=67 HTTP/1.1" 200 2587 16 "https://jira.mysite.com.au:2053/servicedesk/customer/user/signup" "Mozilla/5.0 (iPhone; CPU iPhone OS 14_4 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/87.0.4280.77 Mobile/15E148 Safari/604.1" "2i9nbo"
0 votes
Dirk Ronsmans Community Leader Mar 09, 2021

Hey @Matt ,

If this is an urgent issue (which it sounds like) you might be better of submitting a ticket instead of relying on the community for this.

https://support.atlassian.com/contact

if you have an active maintenance contract they should be able to help you out quickly.

Tried that yesterday. They didn't help.

I don't have a maintenance contract.

Dirk Ronsmans Community Leader Mar 09, 2021

As in, no reply or "we cannot help because of some reason"?

i'll add them on this question but this is still a volunteer based community.

As a hail marry could you open the developer console and see what comes up when you do click the button?

They wanted my SEN number, but I didn't provide it because I've been using JIRA since 2016 and support expired long ago for me. So they didn't bother assisting me further.

Sure, I actually tried that and I was getting a 400 error back (as seen in the logs above).

09_MAR_2021_02_26_06_28.PNG

What's strange is, I can sign up on the link below and it does work. However, that is only for signing up for the JIRA Software (the bug tracking side). It does not give users access to the Service Desk side which is really strange. You would think that both registration options would work the same systems (Service Desk (AKA: Service Management) and Software).

https://jira.mysite.com.au:2053/secure/Signup!default.jspa

 

Dirk Ronsmans Community Leader Mar 09, 2021

Well if your support is expired then I can't blame then. Those maintenance contracts exist for a reason so that makes total sense to me.

Guess you're stuck with us then ;-)

400 is a "bad request" so that's gonna be a tricky one.

Did you first test this on a staging environment or just went for it on production?

Have you already tried going in to safe mode to see if any plugin's are causing issues?

I updated on my production environment. I have not tried safe mode, I am going to try that now (will report back once done). UPDATE: Safe mode did not change a thing.

Yes, a 400 error is going to be hard to find, but this is the only page which seems to trigger the 400 error so I'm starting to believe it's a bug in Atlassian's code. Everything else on my system seems to be functioning and operating normally.

Dirk Ronsmans Community Leader Mar 09, 2021

wouldn't be the first time a totally different plugin causes some issues where you don't expect it.

If safe mode works then I'd suggest enabling your apps one by one to see which one causes the issue.

Also are you using a proxy that maybe translates the request for the portal? (I'm just thinking of all the things that could have an impact).

 

Otherwise, I hope you have a backup and that you can restore to your previous version..

I'm not using a proxy. My server.xml is as followed.

https://ctxt.io/2/AACgjfBLEQ 

Mirror: https://justpaste.it/94eg5 

Small update. I installed Jira from scratch on a Virtual Machine and it's completely different from my production system. What the hell is going on?! I might copy all the core files from the new install over my existing production installation because I now have a feeling the core files did not automatically update correctly and the Atlassian installer is completely broken.

09_MAR_2021_11_54_06_60.PNG09_MAR_2021_11_54_19_07.PNG

Of course, enabling CAPTCHA results in it appearing too, and when I click on "Sign Up", it responds correctly (unlike mine which is completely f**ked up).

09_MAR_2021_11_59_35_39.PNG09_MAR_2021_11_59_50_01.PNG

Dirk Ronsmans Community Leader Mar 09, 2021

Weird.

Did you link the same database on your new virtual machine? Cause that would contains settings of course and addons that might not be in fresh install compared to your production one.

Perhaps it might be a better suggestion to uninstall your production environment and reinstall it (but of course keep your application data folder to not lose your apps, unless you want to reinstall those)

90% of your settings is in the database anyway.

No, the Virtual Machine was using a new embedded H2 database.

Yep, I'm working on that right now. If it still doesn't work, then I'll manually check each setting and if I can't find any issues there it would be a database issue for sure.

I will keep you updated and reply back shortly.

 

Now I'm not getting any CAPTCHA. Same issue also persists.

10_MAR_2021_12_50_40_64.PNG

Okay, I reinstalled everything from scratch and added my existing database. Same problem persists from my first post. I am getting a CAPTCHA image now, but when clicking on "Sign Up" it does shit all.

Dirk Ronsmans Community Leader Mar 09, 2021

Language @Matt Language.. ;-)

  • Did you try the safe mode?
  • Which addons do you have installed?

Seems it works with a fresh DB and not with your DB so must be something in your DB then. If you try it with Safe mode and it works (can't see that you tried that yet) try enableing the addons one by one to see what might cause it.

Are all your addons up to date? Are they all compatible with 8.15/4.15?

Sorry, getting really frustrated now.

  • Yes, I tried safe mode. No change.
  • I only have the core addons that JIRA comes with. I never added anything custom or installed anything from the plugins store. I mean, I literally just installed a new production system. The only thing I added was my data directory into the Application Data directory and the server.xml file plus dbconfig.xml file into their correct locations as needed.

If it's something in my database, that's really strange because I don't see how that would affect a web page (unless the pages are actually in the database). This is something an expert would need to address, and if so, tell me at what location in the Microsoft SQL database these pages are and how I can force update them.

Dirk Ronsmans Community Leader Mar 09, 2021

Then I'm afraid my bag of tricks is also empty.

I agree that an expert (preferably someone from Atlassian) would need to take a look at this. (maybe by sending your support.zip)

As you don't have an active maintenance contract that's more difficult of course. (and maybe something to reconsider).

I've escalated the issue here on the community as well to Atlassian so we'll see if they find their way here.

All I can suggest in the meantime, restore a pre-upgrade database and Jira version and test this out properly on a staging environment.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Announcing Mindville Insight is now part of Jira Service Management!

Hello Community! We’re excited to announce that Mindville Insight’s asset and configuration management capabilities will now be integrated into Jira Service Management Premium and Enterprise plan...

600 views 9 14
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you