Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Service Desk unable to create project

Hi,

We are in the process of purchasing Jira Service Desk.

I have recently installed Jira service Desk (v3.8.2) on a test server using a production backup of our current Jira Software instance. After the installation I am unable to created any service desk projects.

I get the following error when attempting to create the project:
Hmm... we couldn't create your project due to an unknown error. Try refreshing the page to start again.

The logs show:
Caused by: java.lang.IllegalArgumentException: cacheLoader returned null for key 'SD_REQTYPE'

JIRA Software 7.5.1

2018-03-01 14:57:32,132 http-nio-8080-exec-20 ERROR aa.ss@xxx.co.za 897x1793x1 1yqa74f 10.1.12.52 /rest/project-templates/1.0/templates [c.a.jira.project.ProjectCreateRegistrarImpl] The handler with id com.atlassian.jira.project-templates-plugin:apply-project-template-handler threw an exception while handling a notification about a project being created
com.atlassian.cache.CacheException: java.lang.IllegalArgumentException: cacheLoader returned null for key 'SD_REQTYPE'
at com.atlassian.cache.memory.DelegatingCachedReference.get(DelegatingCachedReference.java:91)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala.com$atlassian$servicedesk$internal$feature$customer$request$requesttype$RequestTypeInternalManagerScala$$getCache(RequestTypeInternalManagerScala.scala:91)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala.getAnyRequestType(RequestTypeInternalManagerScala.scala:152)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala.com$atlassian$servicedesk$internal$feature$customer$request$requesttype$RequestTypeInternalManagerScala$$createChildData$2(RequestTypeInternalManagerScala.scala:124)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala$$anonfun$addRequestTypeUnchecked$2.apply(RequestTypeInternalManagerScala.scala:136)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala$$anonfun$addRequestTypeUnchecked$2.apply(RequestTypeInternalManagerScala.scala:135)
at scalaz.$bslash$div.flatMap(Either.scala:134)
at com.atlassian.servicedesk.internal.feature.customer.request.requesttype.RequestTypeInternalManagerScala.addRequestTypeUnchecked(RequestTypeInternalManagerScala.scala:135)
at com.atlassian.servicedesk.internal.feature.gettingstarted.GettingStartedRequestTypeCreationService.createAndConfigureRequestType(GettingStartedRequestTypeCreationService.scala:419)
at com.atlassian.servicedesk.internal.feature.gettingstarted.GettingStartedRequestTypeCreationService.com$atlassian$servicedesk$internal$feature$gettingstarted$GettingStartedRequestTypeCreationService$$createTypes$1(GettingStartedRequestTypeCreationService.scala:79)
at com.atlassian.servicedesk.internal.feature.gettingstarted.GettingStartedRequestTypeCreationService$$anonfun$createRequestTypesForNewProject$1.apply(GettingStartedRequestTypeCreationService.scala:93)
at com.atlassian.servicedesk.internal.feature.gettingstarted.GettingStartedRequestTypeCreationService$$anonfun$createRequestTypesForNewProject$1.apply(GettingStartedRequestTypeCreationService.scala:93)

 

Regards,
Avinash

1 answer

0 votes

Hello, Avinash! The issue you are experiencing appears to be related to a missed upgrade task. This is due to a known issue that can happen if you had Service Desk installed in Jira 6.4 or older and then upgraded Jira to a newer version, passing Jira 7.0 without having Jira Service Desk installed. This would cause an upgrade task to be missed, which would, in turn, be the cause of the error you are receiving. You can follow this KB Article with suggested workarounds to solve that issue: Problems after upgrading/installing JIRA Service Desk

I hope this helps!

Thanks Rene.

There is a lot of risk involved with the approach for Cause 1. 

Is it not possible to clean up my existing Jira Software 7.5.1 data to remove all the previous Service Desk references?

Hello! 

If your scenario is indeed that you had SD installed time ago, and then uninstalled, time passed, upgraded your instance, and now at 7.5 you experience the issue, it is technically possible to purge the old SD data, although it requires dropping a few tables. The scenario is currently tracked in the feature request JSDSERVER-4732 (please feel free to give feedback there on how this is affecting your experience). You can try following THIS COMMENT from David Yu, which appears to have worked for other users. Remember to back up your database before doing any change!

Hi,

Purging the previous Service Desk information worked for me.  

These where the instructions from Atlassian.

  • Go to JIRA Admin > Application > Versions & licenses, and uninstall Service Desk from this page.
  • You will get a popup with "Also remove my JIRA Service Desk configuration" automatically ticked. Keep this option ticked, and click on "Uninstall"
  • Stop JIRA
  • Run all these queries in the Database:
    • Query to drop the Service Desk tables (the list of tables to drop might be different in your environment. If it is different, please adjust it with the list of tables you got from the Plugin data storage page):

§   §  DROP TABLE "AO_0201F0_KB_HELPFUL_AGGR","AO_0201F0_STATS_EVENT","AO_0201F0_KB_VIEW_AGGR","AO_0201F0_STATS_EVENT_PARAM","AO_56464C_NOTIFICATIONRECORD","AO_56464C_APPROVERDECISION","AO_56464C_APPROVER","AO_56464C_APPROVAL","AO_4E8AE6_NOTIF_BATCH_QUEUE","AO_4E8AE6_OUT_EMAIL_SETTINGS","AO_D530BB_CANNEDRESPONSE","AO_D530BB_CANNEDRESPONSEAUDIT","AO_D530BB_CRAUDITACTIONDATA","AO_D530BB_CANNEDRESPONSEUSAGE","AO_54307E_CAPABILITY","AO_54307E_ORGANIZATION_PROJECT","AO_54307E_SERIES","AO_54307E_ASYNCUPGRADERECORD","AO_54307E_SLAAUDITLOG","AO_54307E_VIEWPORT","AO_54307E_OUT_EMAIL_SETTINGS","AO_54307E_VIEWPORTFIELDVALUE","AO_54307E_CUSTOMGLOBALTHEME","AO_54307E_EMAILCHANNELSETTING","AO_54307E_QUEUE","AO_54307E_GROUP","AO_54307E_EMAILSETTINGS","AO_54307E_METRICCONDITION","AO_54307E_PARTICIPANTSETTINGS","AO_54307E_SLAAUDITLOGDATA","AO_54307E_STATUSMAPPING","AO_54307E_TIMEMETRIC","AO_54307E_SERVICEDESK","AO_54307E_VIEWPORTFORM","AO_54307E_SUBSCRIPTION","AO_54307E_CUSTOMTHEME","AO_54307E_IMAGES","AO_54307E_ORGANIZATION","AO_54307E_SYNCUPGRADERECORD","AO_54307E_ORGANIZATION_MEMBER","AO_54307E_THRESHOLD","AO_54307E_GOAL","AO_54307E_REPORT","AO_54307E_GROUPTOREQUESTTYPE","AO_54307E_CONFLUENCEKB","AO_54307E_QUEUECOLUMN","AO_54307E_VIEWPORTFIELD","AO_54307E_CONFLUENCEKBENABLED","AO_54307E_CONFLUENCEKBLABELS","AO_9B2E3B_IF_CONDITION_CONFIG","AO_9B2E3B_IF_COND_EXECUTION","AO_9B2E3B_THEN_EXECUTION","AO_9B2E3B_RULESET","AO_9B2E3B_IF_THEN_EXECUTION","AO_9B2E3B_RSETREV_PROJ_CONTEXT","AO_9B2E3B_RULESET_REVISION","AO_9B2E3B_THEN_ACT_CONF_DATA","AO_9B2E3B_RULE","AO_9B2E3B_RULE_EXECUTION","AO_9B2E3B_PROJECT_USER_CONTEXT","AO_9B2E3B_WHEN_HAND_CONF_DATA","AO_9B2E3B_WHEN_HANDLER_CONFIG","AO_9B2E3B_IF_THEN","AO_9B2E3B_THEN_ACTION_CONFIG","AO_9B2E3B_EXEC_RULE_MSG_ITEM","AO_9B2E3B_IF_COND_CONF_DATA","AO_9B2E3B_RSETREV_USER_CONTEXT","AO_9B2E3B_THEN_ACT_EXECUTION","AO_9B2E3B_IF_EXECUTION","AO_C7F17E_LINGO","AO_C7F17E_PROJECT_LANGUAGE","AO_C7F17E_LINGO_REVISION","AO_C7F17E_LINGO_TRANSLATION","AO_C7F17E_PROJECT_LANG_CONFIG","AO_C7F17E_PROJECT_LANG_REV";

    • Queries to delete Service Desk upgrade history:

§   §  delete from propertytext where id in (select id from propertyentry where entity_name like 'com.atlassian.servicedesk%' and propertytype='6');§   §  delete from propertyentry where entity_name like 'com.atlassian.servicedesk%' and propertytype='6';

    • Query to clear the pluginstate table:

§   §  DELETE FROM pluginstate where pluginkey like 'com.atlassian.jira%';

Hi

Was your problem solved with the above method?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

ThinkTilt is joining the Atlassian Family!

This morning, Atlassian announced the acquisition of ThinkTilt , the maker of ProForma, a no-code/low code form builder with 700+ customers worldwide. ThinkTilt helps IT empower any team in their or...

293 views 16 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you