Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Insight Discovery finding objects but not adding them

I had configured the Discovery app using Discovery -s and set the IP range; ex. 192.168.1.0/24 and let the Discovery agent scan my subnet. 

I knew I had 46 servers on this subnet. The Discovery agent found all 46 and brought back successful pings for each one during the test. So I ran the Discovery agent, grabbed the zip file and uploaded it. When the upload finished, 4 new servers had been added. Out of 46.

 

I grabbed the individual IP addresses for all the servers that didn't upload, input their individual IPs into the Discovery settings and had it scan again. Again the ping test identified all successful connections and the scanner took a good 30 minutes to finish its scan so I knew it was grabbing information. When it finished it said it successfully found 14 additional objects. I uploaded that zip file and 2 more servers were added.


What is going on? Why does the Discovery say its finding and scanning my servers but when I actually import the data, it doesn't upload them?

 

1 answer

Hi Garren,

Did you check if the port 51337 is accessible for all those 46 servers?

That is the used port by the agent.

I had some issues in my last scans because of the state of this connection.

I have not verified this. I will do so in the morning and get back to you guys. Thanks for the reply!

I bet thats part of it since we have a very restrictive firewall.

Gustavo. Thanks for the advice but unfortunately it didn't help. I verified the port was accessible for all servers and I ran the scan again but no change.

Hi Garren,

I see. Have you extracted the zip file to check the XML files and ensure if all servers were scanned?

Maybe the problem is in the import configuration.

For curiosity, are you using Jira DC/Server or Cloud?

Our Jira is stored in our own amazon cloud service. 

 

I can extract the XML files but I dont really know what I'm reading. I've never looked at xml...or any kind...of code before. Are there any documents I can read that would teach me how to read the xml file? Is there anything specific I should be looking for in the file?

I am not sure about that.

Maybe you should open a ticket with Atlassian to see what is going on.

Also, I don't know if you have already done this, but in Discovery logs directory, you can try to find the log file related to the agents, and verify how many hosts were scanned. That way you can make sure if the problem is in your scan or Jira import.

The log will show something like this:

08/06/2021 20:19:17 : -------------- Agent check Statistic --------------
08/06/2021 20:19:17 : Possible IPs: X
08/06/2021 20:19:17 : Reachable Agent-Clients: X
08/06/2021 20:19:17 : Unreachable Agent-Clients: X

I actually thought this was the ticket system since there isn't any "open support ticket" option in the Help section of my Atlassian settings.

 

I couldn't find any email address or support page that allowed me to open any ticket. Just this community forum. So I assumed this was their support page.

 

I've never seen the log files so I'll see if I can find that and read it. Thanks for the help.

this is what I got from my log file:

 

6/4/2021 9:32:16 AM : -------------- Discovery scan Statistic --------------
6/4/2021 9:32:16 AM : Possible IPs: 254
6/4/2021 9:32:16 AM : Unreachable Host/Devices: 208
6/4/2021 9:32:16 AM : Reachable Host/Devices: 46
6/4/2021 9:32:16 AM : Full-Scanned Hosts: 3
6/4/2021 9:32:16 AM : Canceled Hosts: 8
6/4/2021 9:32:16 AM : Deleted Hosts (Unknown): 35
6/4/2021 9:32:16 AM : Full scan time 1884 seconds with 4 threads.

 

it looks like it only fully scanned 3, deleted 35 (no clue what that means or why) and ignored 8 (no clue what that means or why)

Try to raise your problem on the following link: https://support.atlassian.com/contact/#/

About your log, I believe you are using Discovery scan over the network and not the Discovery agent as I thought.

In this case, I believe you have to check if your servers are accessible by port 22 (Linux) or 135, 5985 (Windows). Also, validate your configured credentials in Discovery.

 

I hope that was helpful.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June ask me anything (AMA)

Hello Community members! We’re wrapping up the end of JSM June with an Ask Me Anything (AMA) with the Jira Service Management product team. This is your chance to ask all your ITSM questions to o...

159 views 9 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you