Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,726
Community Members
 
Community Events
165
Community Groups

Insight Discovery failing during transport process

I have a servers that I'm working on discovery objects within the organization - a set of servers to begin with.  The scan is able to scan the servers, gather information, it creates the two xml's with the data, states that it creates the zip file - but then errors out - since it is trying to move the file.  I'm not sure why it is trying to move it, and where it thinks it needs to move it.  I'm aware of the bug that Insight Discovery has, with the file export directory, but I have verified the setting is there, and validates to be the "scans" directory.  

 

Not sure if anyone has seen anything like this or not, thought I would ask.

 

The end of the discovery log:

5/2/2022 1:49:46 PM : Full scan time 45500 seconds with 3 threads.

5/2/2022 1:49:46 PM : -----------------------------------------------

5/2/2022 1:49:46 PM : saving file: 30628_00001_Hosts_2022-05-02_1349_0396.xml to folder D:\Insight\Discovery\scans | binary = False

5/2/2022 1:49:46 PM : Start package process for: 30628_00001

5/2/2022 1:49:46 PM : Adding file 30628_00001_Hosts_2022-05-02_1349_0396.xml to package.

5/2/2022 1:49:46 PM : Adding file 30628_Discovery_Settings_2022-05-02_1349_0922.xml to package.

5/2/2022 1:49:46 PM : Finish building package: D:\Insight\Discovery\scans\30628_00001_2022-05-02_1349_0809.zip

5/2/2022 1:49:46 PM : Deleting file: D:\Insight\Discovery\scans\30628_Discovery_Settings_2022-05-02_1349_0922.xml

5/2/2022 1:49:46 PM : Deleting file: D:\Insight\Discovery\scans\30628_00001_Hosts_2022-05-02_1349_0396.xml

5/2/2022 1:49:46 PM : Start transport process.

5/2/2022 1:49:46 PM : Transferring file 30628_00001_2022-05-02_1349_0809.zip to export path D:\Insight\Discovery\scans

5/2/2022 1:49:46 PM : Could note move file : 30628_00001_2022-05-02_1349_0809.zip

5/2/2022 1:49:46 PM : Exceptions:

5/2/2022 1:49:46 PM : Could not find file 'D:\Insight\Discovery\scans\30628_00001_2022-05-02_1349_0809.zip'.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

   at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)

   at Insight.Discovery.Logic.FileTransfer.TransferFile() in C:\Source\discovery\Discovery\Logic\FileTransfer.cs:line 78

5/2/2022 1:49:46 PM : Finished transport process.

1 answer

1 accepted

0 votes
Answer accepted

The newest version of the discovery application solved a few issues.  One, the export directory for file output should be set to your <Insight Install Directory>\import.    The newest version has allowed that setting to remain and does not get wiped out. 

I've also learned, that Windows 2019 Server is difficult to use - there is a compatibility issue that can be worked around as stated in documentation - but I returned to all 2016 servers and discovery has been working relatively well. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Service Management

Jira Service Management Documentation Opportunities

Hello everyone, Hope everyone is safe! A few months ago we posted an article sharing all the new articles and documentation that we, the AMER Jira Service Management team created. As mentioned ...

329 views 0 10
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you