Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,198
Community Members
 
Community Events
176
Community Groups

I have downloaded Assets Discovery on a linux system as well as mono but the exe files do not work?

Hello there,

I have downloaded Assets Discovery for server and followed this documentation to the tea. I have mono downloaded and it is a higher version than the suggested minimum. I have unzipped the Discovery files and when I run the executables I get this error. Does anyone know how to debug this? 

Screen Shot 2022-11-25 at 12.06.52 PM.png

https://confluence.atlassian.com/insightapps/using-discovery-on-a-linux-system-1085180648.html 

1 answer

0 votes

Hi @cami 

This looks like your Discovery_3 directory is not in your PATH.

What happens if you type the following from that Discovery_3 directory?

mono ./Discovery.exe -s

I get the same error.

What are the permissions for Discovery.exe?  Can you run "ls -l" on the directory and show the output?

Screen Shot 2022-11-28 at 10.05.57 AM.png

Screen Shot 2022-11-28 at 10.06.41 AM.pngScreen Shot 2022-11-28 at 10.07.21 AM.png

I have also tried mono <full directory path>/Discovery.exe -s

How did you install mono?

Did you use the following?

sudo apt install mono-devel

If you did, that works for Windows code you have to compile.

I think you have to install mono this way:

sudo apt install mono-complete

Screen Shot 2022-11-28 at 2.50.15 PM.pngI installed mono by following the instructions here for ubuntu. This is the version I am running (included in the screenshot). I have also run the sudo apt install mono-complete command and it made no difference  https://www.mono-project.com/download/stable/#download-lin 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events