Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,296
Community Members
 
Community Events
168
Community Groups

How do I change reporter after an issue is created?

After an issue is created, I'm unable to change to a different user. The only option to change to is Anonymous. Am I doing something wrong?

3 answers

1 accepted

2 votes
Answer accepted

Hello @Kyle Johnson,

Thank you for reaching out to Atlassian Community!

In order to select another customer as the reporter of an issue, there are two settings that need to be checked.

The first one is the “Browse users and groups” global permissions. Please, go to Cog icon > System > Global permissions and check if the groups you are part of have this permission.

Then, go to the Project settings > Customer permissions (company-managed) or Project settings > Channels > Customer permissions (team-managed) and check if the “Customer sharing” is set to “Customers can search for other customers within their project or organizations”.

Note that, it’s necessary to type the customer’s name or email and it’s only possible to search for existing customers. If you need to add a new customer, it will be necessary to invite them to the project first.

Kind regards,
Angélica

Well I tried that and it didn't seem to change anything. I've attached pictures for you to see.Screenshot 2021-07-13 160227.pngScreenshot 2021-07-13 160321.png

Thank you for testing, @Kyle Johnson.

When you search for the customer on the Reporter field, if the customer exists on the site and have permission on the project, they should appear:

Screen Shot 2021-07-14 at 10.21.38.png

Have you also changed the Customer sharing” to “Customers can search for other customers within their project or organizations”?

@Angélica LuzI wish mine looked like that! Screenshot 2021-07-14 130049.pngScreenshot 2021-07-14 130241.png

As you can see from the screenshots, Cody is a customer, but I still cannot change the reporter to him after the ticket is created. It's any user, I'm just using him as an example.

I also changed that Customer Sharing setting as well.

I'm not sure what I am doing wrong.

@Angélica Luz  Not sure if this is anything to do with it, but when I click on the 'People Tab' at the top of the screen all it shows is view profileScreenshot 2021-07-14 145503.png

Thank you for testing and sharing the details, Kyle.

If you create an issue using the “Create” button at the top, are you able to select a reporter on the “Raise this request on behalf of” field?

Searching the logs on your site, I found some warning messages, but nothing related to your permission:

NEXT-5708 getDefaultReporter: createUsers is true or no default reporter is specified

Message with messageId=<228305b7-xxxx-xxxx-xxxx-xxxxxxxxxx01@Winxxxx-xxxx.xxxxxxxxxxxx.com> has been rejected due to reason=Sender is anonymous, no default reporter specified and creating users is set to false (or external user management is enabled). Message rejected.

It seems that the tickets are being created using the Jira Core mail handler and not the Jira Service Management mail handler, so the reporter is set as anonymous. The best option is to use the project mail handler so the reporter will be set correctly: 

Since you are using Cloud free, those are the only permissions that could prevent changing the reporter.

Can you please go to an affected ticket and open the developer tools on your browser and then search for Cody’s name on the reporter field and check if it shows any error on the console tab.

If it does, then on the developer tools again, click on the Network tab and click on any error that appears (409 errors can be ignored), and check the Response tab. It should show status and a message.

Also, there are browser extensions that sometimes prevent Jira features from working correctly, so please, try using another browser and incognito mode.

Thank you Angelica.

I don't have the option to select one, but I can type in their email address and it will make the ticket under their name. As you can see in the screenshot below, it auto fills with some random number. I just have to edit that and type in the full email.Screenshot 2021-07-15 113414.png

So the way that I have email set now is using our on site exchange server. Everyone is used to email an email address here. It uses IMAP to get and logs into the mailbox. I don't think I understand what you mean about the mail handlers. Is there a better way that I should be doing it? I'm not sure what you mean. I looked at that link you send and there is a lot of information there. I'm just not sure what the best way to be doing that is.

 

I did the developer tools suggestion and it didn't have any issues. I am using Firefox, but I also tried using a brand new install of chrome and internet explorer and it did not do anything different. Screenshot 2021-07-15 113021.png

Thank you for testing, Kyle.

Checking the details and the previous screenshots, I can see that the Browse users and groups permission is set only to jira-servicedesk-users and jira-administrators and you are part of the group site-admins and administrators.

Can you please go again on Cog icon > System > Global permissions and grant permission to those other groups?

Screen Shot 2021-07-16 at 10.06.50.png

Regarding the requests via email, Service Management projects have their own mail handler which is better than the Jira mail handler when it comes to receiving requests from customers.

You can find the mail handler Project settings > Email requests (company-managed) or Project settings > Channels > Email (team-managed). It has an email that is created automatically or you can also add a custom email address. Using the JSM mail handler allows you to view the logs as well where you can check if the ticket was created or if one of them failed, you can see the reason.

The documentation I shared has a list of other documentation that contains the details of how to use it. If you have any other questions, please let us know.

That fixed it!

 

I added myself and other team members as a jira-administrator. That is what fixed it!

 

Thank you for working with me!

Like Angélica Luz likes this

Hoping you can clarify your explanation a bit, as I am having trouble following it.

 

"The first one is the “Browse users and groups” global permissions. Please, go to Cog icon > System > Global permissions and check if the groups you are part of have this permission."

I am in Global Permissions, but there is nothing labeled "Browse users and groups" and it is unclear now to check if the groups I am part of have this permission. I am in the Jira Administrator group, but apparently this group does NOT have the permission to change Reporter.

 

"Then, go to the Project settings > Customer permissions (company-managed) or Project settings > Channels > Customer permissions (team-managed) and check if the “Customer sharing” is set to “Customers can search for other customers within their project or organizations”

I cannot find any "Project Settings" link anywhere in Jira. Can you please advise how to access the menu you are referring to?

Thank you!

How does this work when you CLONE and issue.. The person who clones is different than the originator of the ticket.. how do I get the NEW CLONED ticket to have the person that cloned it as the REPORTER - I do not want the original ticket creator as the reporter..

0 votes

Hello @Todd Green,

Welcome to Community!

When accessing the Global permissions, it should show these details:

Screen Shot 2021-09-01 at 16.25.18.png

Are the Global permissions empty?

If there are no details about the Browse users and groups, it will be necessary to set it to Public (so it will unlock the ability for you to set it to the admin groups). No worries in setting this to Public because it’s just for a few moments and it won’t make your site public. 

Screen Shot 2021-09-01 at 16.47.21.png

At the bottom of the page, select the permission Browse users and groups and set to Public. After that, refresh the page and follow the same steps, but select administrators, site-admins and any other group you need. Then, delete the permission for “Public”.

Regarding the Project settings, it can be found on the left sidebar when you access a project. It’s only available for Project administrators. 

Screen Shot 2021-09-01 at 16.52.01.png

Kind regards,
Angélica

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events