Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Domain verify with DNS

I have added the TXT record and waited a week several times and i am still not able to verify the domain name. Why is jira not seeing the DNS record?

1 answer

1 accepted

0 votes
Answer accepted

@ken yoder - hi Ken! Where are you configuring DNS? Are you with a service like Cloudflare, GoDaddy, etc.?

If I* have personal experience with your service, I can tell you how I've configured my TXT records.

* or someone else on this forum

i am using bluehost for the domain hosting. im adding the "atlassian-domain-verification=***gibberish***" key to my @ TXT records.

Dave Liao Community Leader Jan 20, 2021

Gotcha - Bluehost's DNS config is pretty straightforward (I've actually used them before!).

Have you tried removing the TXT record, then re-applying it?

Sanity check: Your host record should be "@" (no quotes) as you mentioned. And you can re-paste in the atlassian-domain-verification value as you did before.

yes i've added and removed it 3 times. waiting a week in between each time. 

:-(

Dave Liao Community Leader Jan 21, 2021

@ken yoder - bummer! A few hours max should be sufficient time to try again.

I would suggest the HTTPS method of verifying then - way easier if you're your domain server admin (or know one).

our site is hosted on wix and our webmaster tells me that there is no way to upload the verification html file for the HTTPS verification... DNS seems my only option. 

does atlassian have no support options for this type of issue?

Dave Liao Community Leader Jan 21, 2021

@ken yoder - if you're on Atlassian's free plan, free community-supported support (from volunteers like me!) are your primary option.

Can you screenshot your TXT record in Bluehost, so I can sanity check it? Feel free to crop judiciously or redact any entries you consider private.

Capture.JPG

i see... i appreciate your help, this thing is kickin my butt.


Like Dave Liao likes this
Dave Liao Community Leader Jan 21, 2021

@ken yoder - instead of @ , try replacing that with the actual domain's name (it's a stretch), e.g. catsareawesome.com

Dave Liao Community Leader Jan 21, 2021

@ken yoder - also, as a sanity check, put in your domain here: https://dnschecker.org/all-dns-records-of-domain.php

and confirm you see the TXT record present?

Like Prakash likes this

bluehost wouldnt let me use the domain name, it just threw an error. i tried it blank too, same error. the only way it would save is with the @. 

and the txt record is not showing up on dnschecker. 

Like Dave Liao likes this
Dave Liao Community Leader Jan 22, 2021

@ken yoder - that's a weird one! Reach out to Bluehost support to confirm if you've added the TXT record in the right place/format/etc.

If dnschecker doesn't see the entry, Atlassian wouldn't either.

got it... Thanks for your help. 

Like Dave Liao likes this
Dave Liao Community Leader Jan 22, 2021

Please write back if they're able to pinpoint what the issue is! I feel super invested now 😄

haha no doubt. it was my fault... (shame face) i was setting the txt record at bluehost's dns instead of wix's dns. bluehost hosts our domain names but they are routed to wix. i thought the txt records stayed with the domain but apparently they follow through to the endpoint's dns. 

we set the txt record at wix and it worked within an hour. 

Dave Liao Community Leader Jan 26, 2021

@ken yoder ha!! Wonderful. Thanks for sharing your solution - and you can always accept this thread as an Answer since your answer's here! :-D

Like ken yoder likes this
Dave Liao Community Leader Jan 26, 2021

@ken yoder - fun trivia; some domain host providers won't even LET you set DNS records on domains if you're leveraging a different service (like Cloudflare) to handle your DNS records. Now I know Bluehost lets you. 😜

thats weird that it lets you add the record even though it does nothing right? seems weird to me. lol

Like Dave Liao likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

189 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you