Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,328,546
Community Members
 
Community Events
168
Community Groups

Customer organization not displaying in queue

Hi All, 

 

I'm having an problem with my issue queue where customers' issues in the queue are not displaying the organization they are assigned to. 

Capture - organizations.PNG

I've tried everything I could find but I cannot find any solution that seems to address my issue.

 

Further info here, I added the customers through Customers>Add Organization and then added customers to each organization. I found that there was also an option to add Service Desk Customer in the settings (don't understand how that is different to the customers added in the above way either....) but no matter which way I add them (as a SD Customer or not) they still don't populate with their organizations. 

 

Any help here would be really appreciated,

Thanks guys. 

 

3 answers

1 accepted

1 vote
Answer accepted
Dirk Ronsmans Community Leader Oct 28, 2020

@Laura Murphy

The Organisations field on the issue is not automatically filled in (even if the user is in an organisation).

The field on the issue is actually what organisation(s) the issue is shared with.

So a customer can be added to an organisation but if an issue is submitted privately/not shared with that organisation the field on the issue will be empty.

Likewise, if you add the organisation on the issue it will be automatically shared with the rest of the organisation.

Hi @Dirk Ronsmans 

 

Thanks for your response. In that case, how do i go about including customers organizations in the issue queue? (Can this be automatically collected when a customer submits an issue?)

Thanks, 

Laura

Dirk Ronsmans Community Leader Oct 28, 2020

@Laura Murphy

Do you wish to automatically share the issue with the organisation or do you want to display the organisations the customer belongs to? (it could be multiple)

Hi @Dirk Ronsmans 

I have (somehow) sorted out how to capture organization by the customer selecting "share with organization" in the form - I think this was introduced by changing the screen as suggested above.

 

I would like to be able to set the forms to automatically share the issue with the organisation (with the main goal of this being that each issue shows the submitter's organization in the queue) if possible., without the customer needing to select 'share with organization'.

Thanks for your help,

Laura

Hi @Laura Murphy 

Atlassian just implemented a new feature where you can now 'share with organization' by default when request are created.

Please note that this will only work if the requestor is a member with just ONE organization membership.

To enable this option in Cloud:

  1. Click on COG dropdown > Products.
  2. Under Jira Service Management section > Configuration.
  3. On "Should new requests automatically be shared with a customer's organization?"Choose Yes

image.png

The "Share With" field will automatically pick the relevant organization that the customer are in.

image.png

Hope this helps!

Like Dirk Ronsmans likes this

Guys I have read all your comments and I wanted to ask: What if I don´t want to share with the organization? What if I just want to restrict organization or customers from being able to see any of this stuff? How do I do it, so that I see the organization name in the field?

Hi @Laura Murphy 

Welcome to community! Did you check if the Organization field is actually added to the screen of the Project?

Hi @Prince Nyeche 

 

Thanks for your response. I had a mess around with the fields and screens and now there is an option in each form to Share with organization - this now seems to be able to capture the organization (only when selected though, I'll need to work out a way to set this to 'share with organization' by default if it's going to be useful). 

 

To be honest, I'm not 100% exactly what fixed it, but something worked!

 

Thanks for all your help!

Like Marco Brundel likes this

Hi @Laura Murphy ,

I think the Organization field in the issues is not filled and therefore it is not shown in the queue.


Have the issues been created before the organizations have been set up at Customers?

 

regards, Marco

Hi @Marco Brundel 

The organization was created first and then customers created and added to their organization. Once this was done, the issues were submitted. 

Thanks, 

Laura

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Just dropped! New Lightning Talks: Marketplace episodes

  Hi everyone! Want to learn how customizing your Atlassian apps can improve workflows, enhance teamwork, and boost efficiency across your organization? Check out our new, 15-minute Lig...

106 views 0 0
Read article

Atlassian Community Events