Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,290
Community Members
 
Community Events
165
Community Groups

Can you disable Jira's "convert url to page title" feature?

I started noticing this the other day. Any urls that are pasted in a ticket description are being parsed, loaded off-screen, and then replaced with their page titles instead.

When editing the description, you can click on the URL and choose between three options: "Display URL", "Display Inline", or "Display Card." How can I set "Display URL" as default? 

1 answer

1 vote

@Ernst van Dijk -

Based on my experience, the URL display depends on which browser app that one use.  Example in Chrome - the URL will display as the actual http value.  However if you are using Edge, then it comes in the page title.

In the Description field, if you switch the viewing option from Visual to Text, you will see the URL is coded with Wiki style format [link title|http://example.com].  If you don't want the page title, you will need to edit the content by removing [link title|  and the last ] character.

I am not aware the functionality that you mentioned.  It is more than likely that our env is on-prems Data Center, thus we don't see those options.  However the viewing description field content between Visual and Text format are there for both CLOUD and On-Prems.

Hope this helps.

Best, Joseph Chung Yin

Jira/JSM Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

Hi @Joseph Chung Yin , thanks for taking the time to answer.
In my case the this behavior is browser independent, using Chrome as default, but have seen the same in Edge and Firefox

Jira_inline_URL.png

If the inline conversion is set, unlink the URL will display the text, not the URL

Looking into this further.  there is an existing Atlassian case in regards to your ask (a suggestion request to Atlassian) - https://jira.atlassian.com/browse/JRACLOUD-72429?attachmentViewMode=gallery.  I would recommend that you add yourself as a watcher of the request.

There is no solution yet provide.  From the case, it offers two alternative manual workarounds - One was what I have mentioned originally.  Here are the two for your reference -

In order to remove the Smart link from rendering on the new issue view.

  • Paste the Google link for example, once it renders to preview the link
  • Press Ctrl + Z (Windows) or Cmd + Z (MacOS) (this will revert the link to a normal blue link)

Alternative workaround:

  • When inserting the link, be sure to use http:// instead of [https://|https:]. The Smart Card feature will not be activated, and upon visiting the URL, it will automatically redirect to https:// for these services.

Best, Joseph

Thanks, I've upvoted the feature request.

I've checked you're work around using http instead of https and that does not make a difference. Why this is called a smart card feature is beyond my understanding. In my opinion it is annoying. For a ticketing platform this should not have been implemented. Keeping the original URLs is key within the tickets

Like Sebastian Lutter likes this

@Ernst van Dijk -

You will need to use my original suggestion to resolve your ask for now by toggling to TEXT mode and remove the link format regardless http or https

Wiki style format [link title|http://example.com].  Remove [link title| + ], so the only thing left is your URL information.

Best, Joseph

I am working in text mode. So far the answers provided are not acceptable as the solution. It's the new issue view that is causing this problem. If I revert to old issue view the so called smart feature is not enabled.

I regularly paste up to a hundred URL's in a single copy/paste action into a field. The new issue view is slow to respond. I have added several lines of text before these conversions get noticed. Using Ctrl-Z to go back means also I loose my additional text. And only the last converted URL is allowing the option to alter to "Display URL". All the other modified URLs don't offer the option with a single right-mouse click. This option means I waste my  

IMO JIRA/Atlassian is no longer the product worth the money

Like # people like this

It feels like Jira works against me instead of supporting me (the reason I pay money for it). I often paste up to 50 links per task and it is crucial that the links are visible as URL. To apply the mentioned workaround it would took ages for each single Task I prepare. Also forcing the WYSIWYG as default editor is pain in the ass for power users.

Who wants all this heavy CPU load bullshit and "help the most brainless users" features? It is just pain in the ass, makes everything slow for power users and it burns a lot of money (on atlassian AND customers side) without any sense. Stop this madness please!

Hi Sebastian,

I'm using a browser extension now. "Old Issue View for Jira"
https://chrome.google.com/webstore/detail/old-issue-view-for-jira/gieljallemhjkenmfmdpppdncfcgiceg

Works quite well

I am also having this issue now that Jira is forcing my users to use the new view. Is there any updated method in 2022 where I can disable this feature?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Jira Service Management

Coming Soon: Insight Changing to Assets

The 2020 acquisition of Mindville added powerful asset and configuration management capabilities to Jira Service Management in the form of Insight. Following the completion of that integration, custo...

257 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you