Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,952
Community Members
 
Community Events
177
Community Groups

Can't view attachments after updating to JIRA Service Management 4.15

Hi,

I recently updated my JIRA to 8.15 and Jira Service Management to 4.15. After the update, the attachments in my issues are no longer accessible. The steps are:

go to the attachments section of an issue:

Attachment_ticket.JPG

 

When I click on the link, I get the following:

Attachment_error.JPG

I could still download the attachment. I was wondering if there's a way to check what could be causing this? It worked fine before the update.

Sincerely,

 

Jason

 

4 answers

1 accepted

0 votes
Answer accepted
Pramodh M Community Leader Feb 08, 2021

Hi @Jason Yeung 

Please check whether these files are present in the folder jira/atlassian-jira/WEB-INF/classes/com/atlassian/jira/web/servlet

ViewThumbnailServlet.class

abstractViewFileServlet.class

ViewAttachmentServlet.class

If not present add it from the previous backup copying each files to the location I have specified.

Please let me know if it solved the issue.

Thanks,

Pramodh

Hi @Pramodh M ,

I copied the 3 files from an old backup to the new installation. It didn't fix the problem. I was wondering would I need to restart the JIRA service in order for it to take into effect?

Jason

Hi @Pramodh M ,

I copied the files and restarted the JIRA service. Unfortunately JIRA didn't come up for me. I get the following error:

Restart JIRA2 error.JPG

 

When I removed the 3 files and restarted JIRA service, the site came up file, though the attachments didn't work. My JIRA 8.15 installation didn't contain those 3 files and I copied them from an old backup. It was version 8.5.3. I was wondering if there is something else I could check to get the attachments working?

Jason

Pramodh M Community Leader Feb 09, 2021

Have the new installation of 8.15 in new instance somewhere and copy the files and try. This may be the reason.

And also don't forget to disable incompatible apps.

Hi @Pramodh M ,

I installed JIRA 8.15 on a different machine. When I went to C:\Program Files\Atlassian\JIRA\atlassian-jira\WEB-INF\classes\com\atlassian\jira\web\servlet, I found the 3 class files you mentioned are not there. Below is what's in this directory sorted alphabetically:

MissingServlets.JPG

Pramodh M Community Leader Feb 10, 2021

Hi @Jason Yeung 

Apologies for the mistake, it should have said LTS Version, which is currently 8.13.3

Here's the link to files, download them have copied to the path if you have installed it on Linux

/opt/atlassian/jira/atlassian-jira/WEB-INF/classes/com/atlassian/jira/web/servlet

In windows you know...

The links to files are here

Thanks,
Pramodh

Pramodh M Community Leader Feb 11, 2021

Hi @Jason Yeung 

Did you check with adding files and restarting the server.

Let me know if it solved the issue.

Thanks,

Pramodh

Hi @Pramodh M ,

I tried doing this on our sandbox environment and it worked. Thanks a lot!

I'll need to get approval to make the change on the production environment, but it'll probably work as the JIRA versions are the same for both. (I used the same installation program.).

Sincerely,

Jason

Like Pramodh M likes this

@Jason Yeung I did this in a sandbox environment as well but it hasn't resolved it for me. I noticed that the image you posted showing the files were not located where @Pramodh M said showed this way for me as well, but there is a "viewfile" folder at the top of that list that does have all 3 files in it.

Being that my existing Jira home and install directories are coming from version 7.6.2 and migrated to 8.20.2 I figured the location change was just part of the new structure for the latest version.

Either way, copying those same files over still didn't work for me.  Any assistance would be appreciated, thanks.

I wanted to add that I downloaded the same 3 files and tried them and still have the same problem.

Just for my clarification - is Atlassian omitting code from newer versions which can result in failed in-place upgrades which they advertise as supported?

If so - why are they not at least providing a JAR for these classes that one could deploy to resolve the issue quickly?

Also begs the question of what other pieces of code may have been "omitted", and what their impact may be that we're just not being affected by so egregiously ...

Pramodh M Community Leader Sep 16, 2021

Hi @Diego Rivera 

This was in Older version, its resolved in latest version and even in LTS latest version.

Thanks,
Pramodh

I have 8.19.0 and it's still affected, verified. I had to put the files in a JAR and put it in the WEB-INF/lib directory via Docker magic.

If you're referring to 8.19.1 - it's available(ish) in Docker Hub already but not tagged consistently so I'm going to wait a few days.

It's a shame it took so long to fix such an egregious mistake, though.

Cheers!

Nope. Spoke too soon.

I can confirm that the container tagged with 8.19.1-jdk11 (which is identical to 8.19.1-ubuntu-jdk11, digest 96a85db0b2cc), available in Docker Hub, is 100% afflicted with this issue.

Cheers.

0 votes

Hi @Jason Yeung,

  1. Have you updated all the installed apps to the latest compatible version?
  2. You can try to use a different browser or Incognito/Private mode to rule out anything to do with the web browser.
  3. If you have a reverse proxy, you might want to bypass the proxy and see if the issue still persists.

Hi @mogavenasan ,

There were some installed apps that are not compatible with JIRA 8.15. I'm waiting for the developer to respond. I tried different browsers and the problem persists.

Jason

You can disable all the installed apps to rule out them; Disabling and enabling apps.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.15
TAGS

Atlassian Community Events