Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation error on transition.

I am trying to implement on my Service desk the predefined Automation where a comment (from anyone, customer portal) will re-open my ticket. 

Rule works until the Transition step, where i get the red "Error"

 

Here is what i do know about this particular transition I am trying to use in this Automation 

1. It is in the workflow being used in this project. 

2. It is not linked to any screen

3. Transition works when use manually in Service Desk Agent end. How ever it does not set resolution to configured "Unresolved" as set. 

 

What are all the requirements for the transition to work? 

4 answers

1 accepted

0 votes
Answer accepted

Hello Skuli,

Would you please be able to provide screenshots of the error you are seeing?

Thanks,

Kian

Ok I got the thing to work.  How ever now the transition is not changing the resolution to "Unresolved" as configured.   See below. 

 

sShot.JPG

Skuli,

 

This is because what you are configuring only applies to when a customer uses the button on the portal to reopen the ticket.  Instead, click on Post Functions .sShot.JPG

 

Once there, click Add post function.

At the very bottom you should see the Update Issue Field post function. Add that.

Screen Shot 2020-03-18 at 9.50.32 AM.png

Then pick the field Resolution, and the value None.

Screen Shot 2020-03-18 at 9.50.45 AM.png

Like Skuli Sigurdsson likes this

Flawless victory!!!!

 

Thank you Kian.  I might have some more in coming days. 

 

brgds

Skuli

"Flawless victory" :) I like that phrase! I might steal it!

The same error, the same condition, but it does not work stably. then the transition is triggered, then the transition is not triggered

Hi hi Radhika.  Did you follow the steps above from Kian?  

I'm facing your original problem actually where I'm getting an error for the transition. The solution to that hasn't been mentioned in the above responses yet.

Error.png

Same as your case, all the following points satisfy my case:

1. It is in the workflow being used in this project

2. It is not linked to any screen

3. Transition works when use manually in Service Desk Agent end

I'm still getting the error and am unable to figure out the problem.

 

Thank you in advance!

@Skuli Sigurdsson How did you get it to work? I'm currently facing the same problem.

Hi and sorry for late answer.  I followed Kian´s steps and voila...worked perfectly. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM Jira Automation: How to Send SLA Breached Notifications

Hi Everyone, In   this tutorial,  we will show you how you can monitor an SLA, and send notifications before or after the SLA has been breached.   SLA Threshold Trigger The SLA t...

632 views 5 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you