Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Approval button on Customer portal not visible

Edited

Hello,

using Jira SD 4.5

I'm really confused because the approval button is not visible on Customer portal.
I follow steps on this page: https://confluence.atlassian.com/adminjiraserver/configuring-jira-service-desk-approvals-938847527.html, and I have another workflow on which Approval is setting up correctly, and visible.

The user picker (multiple) is correctly setup on the project / creation screen.
The button is visible on "classic" Jira view, but not on customer Portal.

 

1.jpg

 

did I miss something ?

thanks in advance
Xavier

3 answers

Dear all,

sorry, I came back to this request as it seems still not resolved.
Indeed, after some customer feedback, we are still facing issue.
Sometimes (this is what we try to determine...), the approvals button are not visible in the Customer portal:

a user that is in approval field will see for one ticket the buttons, and the week after, for another ticket (without any change on workflow), buttons will not be available / Visible.

I can reproduce the issue by login in with the customer account. On top right, there is notification to approve some tickets, but when clicking on it, no buttons are available..

 

This is really annoying, as we use this approval process for our new project, and sometimes customer contact us because they can't approve..

 

Is there a way to check what can cause this bug ?

regards,

Xavier

Hi all,

I come back to this topic, because, still not solved.
indeed, on my same workflow, the customer request type depends of a Select custom field value.

for 3 / 4 of customer request type button appears (I can see by login as approvers on customer portal). But for a certain type of Customer Request, buttons never show.

I'm really disturbed because I use only one workflow, I checked the custom field used for the approval, and it's correctly set.

 

any help will be appreciated.

regards,
Xavier

Hi @D X

Is the issue still disturbing you?

Can you share the screenshot to check it?

Hello @Imdad KP _Spectrum Groupe_ 

 

not now. for the moment I cross the finger, issue not reappear..

my bad, we just have a new case...

Can you share the screenshot to check?

Hi Xavier,

I believe you can add the approval status to the portal from the request type. Find the request type, select Edit fields, select the Workflow Statuses tab near the top, enter a portal friendly name for the Approval status, and select Save. Cheers!

Hi Joshua,

thank you for your answer. Unfortunately it doesn't work. I update also name for workflow status, but change anything. My issue is correctly associated to the request type, but definitively, no button appears :(

In addition, the Jira is a development version (but I supposed all the add-on / tools worked as on prod server ?)

regards,

Xavier

Hi Xavier,

Are you, or the person verifying the button appears in the portal, set as the approver for that status? The button will not appear for people who are not allowed to approve. You are correct, a development or trial license will function the same as a production license. Cheers!

Hi Joshua. Yes I am. This tips seems working correctly on our production server, but not on test.. may be I missing something, but don't really know what.

 

regards

Hello

I recreate a full issue type / worflows the simpliest I can, and I have the same issue.

using approvers as custom field, this one is allow on all project. my customer request type is correctly setup, and all fields have been added / visible on customer request screen.

I'm admin of Jira

I see the buton on Jira view

I disable all add-on.

the link of "Approve" button send by mail didn't work (return a blank page).

any suggestion ?

regards

Xavier

Hi Xavier,

I am unable to offer specific assistance without reviewing the configuration directly. You should review Atlassian's page for Setting up Approvals and go over your configuration piece by piece. You may want to perform a side-by-side comparison of the working and non-working configurations. Cheers!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM Jira Automation: How to Send SLA Breached Notifications

Hi Everyone, In   this tutorial,  we will show you how you can monitor an SLA, and send notifications before or after the SLA has been breached.   SLA Threshold Trigger The SLA t...

701 views 5 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you