It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

What would cause "A issue type with ID '10600' does not exist."?

I am trying to assign an issue type a workflow scheme. When adding the error "A issue type with ID '10600' does not exist." is displayed. This error occurs when I try to add this particular issue type for any existing workflow.

1 answer

1 accepted

0 votes
Answer accepted

Hi William,

You may be running into the bug found at JRASERVER-43260 - Cannot Edit Workflow Scheme with error Issue Type does not exist:

Cause:
The Issue Type has been deleted but it is still linked to the workflow.

Steps to Reproduce

  1. Delete any issue type for that is being used by an active workflow.
  2. Attempt to edit the workflow scheme.

Expected Results

Workflow scheme is editable.

Actual Results

You will encounter an error similar to "A issue type with ID '10200' does not exist.
The ID will be different but the error message will be the same.

Workaround

Option A) Recreate the Workflow Scheme from scratch (not Copy scheme as the copy contains the corruption) and reassign Projects to that new Scheme.

Option B) Manually fix the database:
The current discovered workaround is to find the Scheme Entity in the DB and remove it, which will remove the link between the issue type and workflow. The following SQL was run in the DB to remove all traces of the issue type that had been deleted. Please note that the issuetype (in this case '10200') will be the number in the error message.

select * from workflowschemeentity where issuetype = '10200';
  id   | scheme |        workflow        | issuetype
-------+--------+------------------------+-----------
 10706 |  10700 | FDBUGS Workflow | 10200
(1 row)

Manually delete the relation of that Issue Type to active and inactive workflow schemes:

delete from workflowschemeentity where issuetype = '10200';
delete from draftworkflowschemeentity where issuetype = '10200';

Take a look at the steps above and see if that fixes it.  If so please vote on JRASERVER-43260 to add impact and you'll be notified when there is an update to the ticket.

Cheers,

Branden

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira Service Desk

Tell us how you've implemented Change Management

Hello Community 👋, I'm a product manager at Atlassian, looking at improving change management capabilities across our products. In particular, we're looking at bridging the gap between Dev & ...

336 views 0 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you