Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to delete request type if associated issue type no longer exists Edited

My service desk project came with 5-6 issue types. I deleted a whole bunch of them and kept 2. 

Then I went into Project Settings > Request types and tried to delete an existing request type that was mapped to one of the deleted issue types. It shows the delete confirmation popup and shows that it's doing something, but it's just stuck. 

Has anyone else come across this issue? Any suggestions?

1 answer

1 accepted

0 votes
Answer accepted

Hi Maliha,

Welcome to Atlassian Community!

Just for us to better understand and help you with this issue, I’ll make some questions:

  • As per the details you provided, you are using a classic project, is that correct?
  • Can you open the developer tools on your browser and try to delete the request type? Please, check if it will show some error and send a screenshot to us.
  • Have you completely deleted the issue types on Jira settings > Issues > Issue types or you removed them from the project only?

I tested here on a classic project, and when deleting the issue type, the request type is automatically deleted. On next-gen projects, the issue type and request type are the same, so this error shouldn’t appear.

Looking forward to the details.

Regards,
Angélica

Hi Angelica,

Thanks for your quick response. 

  • I'm using the demo project that comes with the SD set up.

Screen Shot 2019-09-26 at 9.57.32 am.png

  • I completely deleted the issue types. 

The odd thing though is that when I go into request types now, the old issue type linking doesn't show anymore. It has linked the request to one of the remaining two issue types. So maybe it just didn't refresh at that time? Although I did try on a new browser window multiple times.

Screen Shot 2019-09-26 at 9.59.10 am.png

So the issue I was facing seems to have been resolved for now. But could have a deep-rooted cause that you may want to investigate.

Thanks for your help.

Thank you for the details Maliha. 

I tried to replicate this behavior and to be honest with you, I got surprised that the request type was deleted once I deleted the issue type. I thought that it would still appear the request type and I would face the same issue as you. 

When we remove the issue type from the project, we face this issue where the request type can't be removed until you put back the issue type, remove the request type and then remove the issue type again.

If you were still facing the issue, the next steps would be us removing the request type from the database, because even if we create an issue type with the same name, the ID would be different and it wouldn't work.

I'm glad that everything is now working as expected, maybe it just took a while to update this information in the database.

Have a great weekend!

I think you're right. Thanks for your help. I appreciate the quick action you took on this ticket.

 

I think we're fine to close this ticket for now. 

Like Angélica Luz likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Desk

The Complete Guide to Atlassian for ITSM

Hi Atlassian Community! This is Teresa from the Atlassian team. My colleague Paul Buffington @Buff and I are excited to share a brand new ITSM resource we’ve created – "The Complete Guide to At...

2,151 views 15 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you