Service desk not showing

I've just installed JIRA Software and Jira Agile (v. 7.4.3) and installed JIRA Service Desk v. 3.64. Everything is installed on CentOS 7 and both have been installed from command line (SCP'ed the binaries to the server, and installed them from the command line). 

Everything shows up as installed on the "Versions & Licenses" page, and I've made sure my user (admin) has access to Jira Service Desk by being in the right group etc. Googled for hours without finding anyone experiencing this, which I find odd. 

Skjermbilde 2017-08-23 kl. 14.42.40.png

I can't find Service Desk in the top menu, and I'm not able to create a new project/service desk, since it *only* shows "Software" and "Business". I'm able to change the project type to Service Desk later, but that doesn't make it a real service desk. 

 

Skjermbilde 2017-08-23 kl. 14.45.41.png

Apologies for the Norwegian screenshots. Just meant to illustrate how I'm not able to create a new JIRA Service Desk servicedesk (intended). Hope someone can assist! 

 

1 answer

1 accepted

1 vote

Hi Marcus,

The first thing I would do is verify Service Desk is enabled under Add-Ons > Manage Add-Ons.  Click the drop-down arrow next to Service Desk and you'll see "X of X Modules enabled."  If there are some modules that are not enabled you can click the link and enable the modules that are not enabled.

If all the modules look to be enabled, restart JIRA and once JIRA restarts take a look at the logs.  There will be an atlassian-jira.log in the JIRA_HOME folder and you should also see an atlassian-servicedesk.log.

Take a look in both of those logs and you may see an error indicating an issue during installation. 

If you see the Service Desk modules are not being enabled for some reason you cannot enable them via the UI, you can enable them directly from the database.

Cheers,

Branden

Thanks for your quick answer, Branden! That's awesome. 

You are indeed right. Most of the modules were disabled. I was not able to manually enable them from the UI, so I went ahead and checked the service desk log on the server: 

Skjermbilde 2017-08-23 kl. 19.03.02.pngI hope that tells something.

I'm also pasting an overview showing what add-ons are disabled: 

Skjermbilde 2017-08-23 kl. 19.06.23.png

I also found some telling evidence in the atlassian-jira.log file: 

com.atlassian.servicedesk.project-ui' - 'JIRA Service Desk Project Plugin' failed to load.
Application context initialization for 'com.atlassian.servicedesk.project-ui' has timed out waiting for (|(&(objectClass=com.atlassian.servicedesk.api.ServiceDeskService)(objectClass=com.atlassian.servicedesk.api.ServiceDeskService))(&(objectClass=com.atlassian.servicedesk.api.license.ServiceDeskLicenseService)(objectClass=com.atlassian.servicedesk.api.license.ServiceDeskLicenseService))(&(objectClass=com.atlassian.servicedesk.api.permission.ServiceDeskPermissionService)(objectClass=com.atlassian.servicedesk.api.permission.ServiceDeskPermissionService))(&(objectClass=com.atlassian.servicedesk.api.portal.PortalService)(objectClass=com.atlassian.servicedesk.api.portal.PortalService))(&(objectClass=com.atlassian.servicedesk.api.sla.metrics.TimeM (....)

Hi Marcus,

That error is saying JIRA timed out before the add-ons could be initialized so there are a few things you can try:

  1. Increase the plugin timeout to 300 or higher and restart JIRA.
  2. Verify you have application memory per the JIRA Sizing Guide, e.g:
    • An application with 60,000 issues would need greater than 8GB of RAM, > 2GB of allocated Heap and a total disk space of 50 - 100 GB.
  3. .  Also, in your logs search for outofmemory which will be an obvious indicator JIRA is running out of Application memory.  

If you find that you need to increase the application memory you can use the instructions in Increasing JIRA application memory and restart JIRA.

Hopefully that helps!

Cheers,

Branden

Thanks Branden. 

I've performed the following steps now: 
1) Increased plugin timeout to 400. Verified.
2) Increaded application memory (x4). Verified. 
3) I only have one entry, which is pasted below (sorry for the verbosity):

 

---------------------- MEMORY INSPECTION FAILED -------------------------------------
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] Unexpected thread found, this probably will cause memory leaks and can result in OutOfMemoryError!
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] ********* Thread #73 commons-pool-EvictionTimer [main] *********
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] threadInfo: ThreadInfo{threadClassName='java.util.TimerThread', threadName='commons-pool-EvictionTimer', threadGroupName='main', classLoaderClassName='org.apache.catalina.loader.ParallelWebappClassLoader', thread=Thread[commons-pool-Eviction$
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] state: TIMED_WAITING
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] priority: 5
2017-07-23 21:23:32,853 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] class: java.util.TimerThread
2017-07-23 21:23:32,854 http-nio-8080-exec-19 WARN anonymous 1282x227x1 1ncz3kr 2.26.105.35 /secure/SetupLicense.jspa [c.a.jira.memoryinspector.MemoryInspector] contextClassLoader: ParallelWebappClassLoader 

--

TOTAL           :  Used:  945 MiB.  Committed: 2704 MiB.  Max: 4182 MiB

Forgot to clarify, that this didn't solve the issue. Same symptoms as last time. 10 plugins fails to load, all of them starting with com.atlassian.servicedesk-xxx

Hi Marcus,

Were you able to check the database and see if you could re-enable the service desk modules that were disabled?

Take a look at Service Desk Installed, but Not Enabled. Found dependent enabled plugins for plugin...

Once you go through those steps let me know the results.

Cheers,

Branden

Only one module was disabled when I ran the query found in that article.

jiradb01=# select * from pluginstate;
pluginkey | pluginenabled
-----------------------------------------+---------------
com.atlassian.jira.plugins.workinghours | false
(1 row)

Tried re-enabling and restarting now. No success :/

Wait, sorry. I went back to verify my steps and see the changes didn't go through to pssql. Now it seems to be up and running!

Thank you so much for your help Branden, and your quick replies. Really appreciate it!

Hi Marcus,

It was my pleasure and I'm glad all is well!

Cheers,

Branden

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

1,227 views 2 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you