Service Desk is not sending any customer satisfaction questions, has somebody the same problem?

The customer satisfaction feedback is activated, but when closing a ticket, the questionnaire is not sent to the customer. Had somebody the same problem and a solution for it?

Thanks

3 answers

Hello Maria,

Satisfaction survey is sent out based upon these two conditions :

1- Issue Resolution is set

2- Request Resolved event is activated

Make sure both conditions are met for the Publication functions in your workflow closing transition.

The Request Resolved notification also must be activated in the notification scheme.

0 vote

Hi Maria,

Have you tried toggling it off and on to see if it kicks in:

 

  • Log in as a service desk project administrator.
  • Select the service desk project you wish to configure.
  • Select Project settings > Satisfaction settings .
  • Disable Collect customer satisfaction feedback
  • Enable Collect customer satisfaction feedback

 

Another thing I would check for is to make sure they are setup to receive they are getting a notification the issue has been resolved:

When you enable satisfaction settings for a service desk project, resolved issue notifications will contain a satisfaction rating scale. Customers can click the rating scale to indicate their level of satisfaction. A confirmation page is displayed on the customer portal, where they can change the rating, and optionally provide any additional comments that they would like to convey to the team.

If they are not getting that notification you'll want to check your notification scheme to find out why they may not be receiving the email.

If you believe the messages are sending but not getting to the recipient you can enable debug mail logging and see what the mail server is doing:

  1. Set up test user that can receive notifications when the issue is closed.
  2. Go to Logging and Profiling.
  3. Click Enable for outgoing mail logging and also Enable Debugging.
  4. Close an issue to test
  5. Disable debug level logging for mail on Logging and Profiling

Once you do that you should see an atlassian-jira-outgoing-mail.log with more information that may be able to help. 

If the logs don't provide any clues and the notification scheme looks good send a screenshot of the notification scheme and any relevant logs snippets and we'll go from there.

Cheers,

Branden

Thanks. We saw that at the new workflow the resolution was not set to resolved. 

 

Now it is working. 

Thanks, 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Asked Feb 02, 2018 in Jira Service Desk

What are the must-have addons?

Hi all, We are trialing Jira Service Desk for a large-ish, flat, team-based organization where members can serve on multiple teams. A few needs that are not out of the box... Assigning i...

908 views 12 5
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you