IMAP POP incoming Mail Server setup fails Edited

hey folks (:

i'm trying to add an incoming mailserver and mailhandler in Jira Servicedesk.

First of all: POP and IMAP are working perfect on our Exchange 2016. I can connect with every client in our environment. Outlook, Mobile Devices etc. 

 

It is possible to set up the incoming mailserver. After that it is not even more possible to connect to the exchange because of 'Authenticate-Errors' like '

  • AuthenticationFailedException: AUTHENTICATE failed.'

However the initial set up is working perfect. If i click after that on 'Test Connection' it fails. Nothing has changed! 

 

In the Exchange-Logs there are Authenticate-Errors too but only from the Jira-Server. I tried the same credentials (in every way like 'domain\user, user@domain' etc.) with different Mail-Clients. Works perfect.

 

  • Certificates are installed on the jira-server
  • POP and IMAP tested. Same problem
  • Credentials and User changed. Same problem
  • Different Ports tested
  • double checked everything
  • checked every KB-Articles from Atlassian. 

 

Summary:

First setup is working perfect. Testing after that fails every time. How can this be possible?

 

Pls help me :/

 

EDIT //

 

samples for correct first login while setting up the mailserver and failed login after setup (when i click test..) below. 

 

Exchange-Log IMAP

AUTHENTICATE SUCCESSFUL

2017-12-20T10:31:34.835Z,0000000000000004,0,x.x.x.x:143,x.x.x.x:34462,,1,0,53,OpenSession,,,
2017-12-20T10:31:34.837Z,0000000000000004,1,x.x.x.x:143,x.x.x.x:34462,,1,13,145,capability,,R=ok,
2017-12-20T10:31:35.082Z,0000000000000004,2,x.x.x.x:143,x.x.x.x:34462,jiratest,236,32,34,authenticate,PLAIN,"R=ok;Msg=""Proxy:ourexchangeserver:1993:SSL;ProxySuccess"";
2017-12-20T10:31:35.088Z,0000000000000004,3,x.x.x.x:143,x.x.x.x:34462,jiratest,0,22,255,CloseSession,,,




AUTHENTICATE FAILED

2017-12-20T10:33:23.878Z,0000000000000006,0,x.x.x.x:143,x.x.x.x:34500,,1,0,53,OpenSession,,,
2017-12-20T10:33:23.879Z,0000000000000006,1,x.x.x.x:143,x.x.x.x:34500,,1,13,145,capability,,R=ok,
2017-12-20T10:33:24.009Z,0000000000000006,2,x.x.x.x:143,x.x.x.x:34500,domain/jiratest,128,32,31,authenticate,PLAIN,"R=""A1 NO AUTHENTICATE failed."";Msg=""AuthFailed:LogonDenied,User: efs\jiratest"";ErrMsg=AuthFailed:LogonDenied",
2017-12-20T10:33:24.009Z,0000000000000006,3,x.x.x.x:143,x.x.x.x:34500,domain/jiratest,0,0,0,CloseSession,,,

 

2 answers

1 accepted

Accepted Answer
0 votes

Odd. I've had a few run ins with setting this up but it usually behaves itself after you try a few things. Let me ask a few questions:

0. Possible tip: Somewhere I saw that some parts of this may be case sensitive. Silly but it may be - especially the user name. Make sure the Host Name and Username are all lowercase. I know I fixed a problem we had by doing that. Worth a shot. Any luck?

1. Is this JIRA Server or JIRA Cloud (I only use Server so if Cloud there may be something I am missing here)

2. " configure the imap-server in Jira Servicedesk in System -> E-Mail"
Specifically are you using System > Mail > Incoming Mail >  Add POP / IMAP mail server? Or is it actually "System -> Email"

3. What about the OUTGOING mail server - can you set that and run "Test Connector" OK?

4. You "enter the credentials, click 'Test Connection' it works". You then click  "Add/Update" to save it, yes? What if you then immediately edit it again if you "Test Connection" does it still work? I ask because you seem to say that you do that THEN create a mail handler THEN it fails. It works OK without a mail handler? You can edit and "Test connection" and cancel and re-edit and it works every time? Or no?

5. On the mail handler you click "Test" and that too fails? Or not?

6. I really can't see how the mail handler can break the mail server - there's really no settings there to do so. You could post a screenshot of the imap page and the mail handler pages - maybe I'll see something odd there. 

7. Try access the JIRA logs (System > Troubleshooting and support tools (might need "Atlassian Troubleshooting and Support Tools" - VERY worthwhile anyway, and free) and get the "JIRA application logs" under "Create support zip" and get "application-logs" - then look at "atlassian-jira.log" and "atlassian-jira-incoming-mail.log" - might have a clue.

8. If all that fails log a ticket with Atlassian. :)

Cheers

0. doublechecked and tested it.

 

1. Jira Server

 

2. It is "Mail > Incoming Mail > Add POP.... i am using it in german so i don't know the exactly description in english :/

 

3. Yes outgoing mails are working perfect. I also can create tickets and the user is getting a mail for his ticket

 

4. If i immediately edit it again it does not work. It does not matter if i click, test twice, save the config and add a mailhandler or save the config and edit it again. Same result

 

5. It fails too on the mailhandler with the same error

 

6 & 7. created Logs and made a ticket with Atlassian

 

8. They found a space in the setenv.sh-file. so the JVM_SUPPORT_RECOMMENDED_ARGS doesn't worked. Maybe that was the problem. Now the mailhandler is working (:

 

9. New problem:

 

Getting license-errors from the mailhandler -.-

If i send a mail to the mailbox from an external domain the mailhandler is grabbing the mail and creates a ticket. Perfect!

 

If i send a mail from our internal domain the mailhandler generates the following error:

Cannot create issue due to invalid license: [Sorry, you can't create any issues right now, as you need to have access to a JIRA application to be able to create issues. To gain application access you need to be a member of a group assigned to an application.]

So what is the difference between external and internal domains here?

-> We have synced our LDAP-User to Jira Servicedesk. The mailhandler recognize that there is a user e.g. Bobthebuilder in Jira Servicedesk because of the LDAP-Sync.

-> Mailhandler expects a Jira-License for this user. Can't find one and then we get the error. This is ridiculous. 

Our mailhandler does not add a user for every new mail. We don't want this. Our users are synced via LDAP and everyone should be possible to add a ticket/create a issue via Mail. If the users are logging in the customer-portal they can create tickets!

In the project-settings we set that every user can send a mail to the project (who can raise requests -> Anyone can email the service desk or raise a request in the portal)

 

Referred to this KB from atlassian https://confluence.atlassian.com/jirakb/incoming-e-mail-cannot-create-issue-in-jira-7-790959539.html there is no solution for us. Still getting the license-errors.

If i add the Anyone Group to Browse Projects i am getting this error and i have to change it back -.-

 

Permission scheme error

 

This service desk project contains permission errors, which can impact functionality. To fix this, upgrade your permissions scheme to copy over your existing scheme and set the required permissions.Learn more

 

Details of which permissions need to be set...

  • Browse Projects permission for the "Anyone" group is not supported by Service Desk.

So #8. fixed it. Great!. :)

On new problem.

a. Yes, I have experienced the "Browse Projects permission for the "Anyone" group is not supported by Service Desk." myself when trying to resolve some issues.

b. Presumably you have "Service desk customer - portal access" in "Project permissions" set for "Create Issues" etc? It sounds like it (and I think that is what Service Desk sets up 'out of the box').

c. I can't remember if it is specifically for the problem you are having or another reason but I have added "Reporter" to the "Create Issues" permission also. I have a feeling that might be the answer to this for you too.

d. If that doesn't fix it can you copy and paste this into a new question? Then you can mark my last answer as "accepted". And then we can work on this new problem separately (and count it as another successful answer if we resolve it). Or if you are feeling extra helpful you could do that anyway and mark it as "accepted" also if #c is the answer. I get "badges" for number of questions successfully answered - lol.

we fixed the problem with the Atlassian support. There was a "space" in the line from the "JVM-Arguments" and that was the reason why it didn't worked -.-

Hi,

Did you resolve this?

I don't quite follow "However the initial set up is working perfect. If i click after that on 'Test Connection' it fails. Nothing has changed!" ---- what is "initial set up"? When you enter the IMAP/POP server details nothing connects (as far as I can see) until you try "Test Connection" or click "Add/Update" to save it. So you (1) click "Add POP / IMAP Mail Server", enter the details ... and then (2) click "Test Connection" or click "Add" and then edit it again and click "Test Connection"?

Also I see in your above logs success is with jiratest but fail is with domain/jiratest. That may be a clue although I am not sure how that would happen (I am presuming your domain is not actually called "domain"?).

Don't know if any of that helps. I have always found the mail server setup a bit finicky but generally ok so I am curious as to why you are having an issue. 

initial setup = configure the pop/imap-server.

-> entering the credentials and exchange-server requirements for the first time when i configure the imap-server in Jira Servicedesk in System -> E-Mail

 

when i enter the credenditals, click 'Test Connection' it works. after saving the config and adding a mailhandler the error occurs. If i edit the imap-config after adding a mailhandler the error occurs also again.

 

domain is just a example like contonso.com which i changed in the log. our domain should not be public because of security reasons (: 

sry for the misunterstanding (:

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 13, 2018 in Jira Service Desk

Jira Service Desk – Don’t be afraid, the journey begins with curiosity!

...be more productive while being fun to use at the same time. For some, getting started can be a bit intimidating. This is especially true if Jira Service Desk is your first exposure to Atlassian...

18,719 views 13 31
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you