It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to remove "Share with Customer" button from a service desk issue? Edited

I've been searching a way to remove Share with customer button in service desk issues.

According to this post (https://jira.atlassian.com/browse/JSDSERVER-4591) there should be a module in Service Desk add-on named "cr-share-request module" which I can't find.

I won't be able to deploy the service desk add-on with that button enabled because it may cause internal comments to be shared with customers by mistake.

Capture.PNG

4 answers

Since the above post didn't worked, lets not take a chance to disable such modules and try. It might lead to other issues.

However, if you are using self hosted JIRA, you can write a javascript to hide it. Find a field in the view screen and write a javascript in the 'Description' of the field in Field Configuration. You can disable or hide the button itself.

Hi thanks for the quick reply,

I haven't done such advanced customization in Jira before. Can you provide any documentation link on that?

The latest was my biggest concern. It seems the comment button is basic for all parts of jira core. Thanks for the info I will look into it.

Here’s how it works:

Open UPM (Manage Add-ons), select “All Add-ons” and search for “JIRA Service Desk” add-on (not "Service Desk Internal Base Plugin" which you've used).

Expand it and click “x of y modules enabled” to show every single module of the add-on. Now, search for the module “cr-share-request” and disable it. If you can't find it, you're searching the wrong add-on.

I've done this and it does not remove the button.

Could you provide a screenshot which button you want to remove?

The described procedure should remove this button and this button only:

share-button-customer-portal.png

Like 1 person likes this

It worked, thanks!

We also need to either disable the "share with customers"-button, or change that the internal comment button is the default button. If someone has a way to do this (like a ready script code), please share it with us. I was able to change the order for the comment tabs with https://community.atlassian.com/t5/Jira-Service-Desk-questions/Default-Service-Desk-Comments-to-Internal/qaq-p/268822.

This problem is driving us crazy as well. So I created a Chrome extension to hide the buttons. 

Cheers, 

I've tried your extension, and it has no effect.  Suggestions?

I think I see the issue in your source code, it's intended for Service Desk Cloud.  We are hosted, so the URL checks won't match.

Yes the public version is intended to only work on JIRA cloud as I didn't enable it to ask for permission to access "all" website data for security purposes.

If you are on hosted, you can clone the Repo, change the manifest and load it in chrome unpacked

That's exactly what I did, works great, thanks!

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Apr 08, 2019 in Jira Service Desk

What's new in Jira Service Desk Server: A stylish new portal in 4.1 - April 2019

Hello Atlassian Community!  I'm Teresa, the Product Marketing Manager   for Jira Service Desk Server at Atlassian. Curious about the latest updates in the Jira Service Desk Server...

359 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you