Disable notification on Status change

Hi,

Here is my notification scheme

Capture.JPG

So my notification are sent to my reporter and to my support team only on Creation, comment, and reopened.

However, when my support team comment a ticket, my customer receive two emails, one with comment of my support team, and a second with header "Status changed to Waiting for customer". Why is it this second notification?

Thanks!

 

 

7 answers

1 accepted

I believe the service desk notification is overwriting the standard notification schemes, you can disable the service desk notifications in Admin > Addons > JIRA Service Desk > Configuration > and turn off notifications, after doing so the standard notifications should take over.

I'm not sure if this will help, as it might completely stop sending emails to your customers, I would recommend installing the JETI plugin and create template emails for your customer when a certain event happens e.g. Issue Updated etc

Joel

It works perfectly when disabling Addon notifications. Thanks!

Molly,

Dunno if you have enought rights, but you can do this only by workaround. 

  1. Go To Service Desk settings
  2. Choose "Request Types"
  3. Choose "Edit fields"
  4. Choose "Workflow statues" tab
  5. On "Status name to show customer", rename "Waiting for customer" and "Waiting for support" to "Open". This way there is no status change to customer, and no notification
  6. Repeat steps 1-5 to each Service Desk and each Request Type 

To get it fixed with real Notification Schema, vote for feature: https://jira.atlassian.com/browse/JSD-914

 

Hi Takar,

that's how the basic Service desk workflow works : each time your support team posts a comment it's interpreted as a question or answer towards the customer and this will send out an email.

I think this is being done using post functions in the workflow of your service desk project.

 

Best regards,

Peter

Hi Peter,

You are right, when I look in my workflow when I look transition 'Respond to Customer" I have a post fonction "Fire a Generic Event event that can be processed by the listeners. ". Bu I can't disable this post fonction, does it means that there is no way to stop this notification unless if I delete (or disable) this workflow?

best regards.

Hi Takar, It's not the Generic Event fired that will cause the mail it's most likely one of the properties of either the Waiting for Support Status or the Respond to Customer step. Jira Service Desk uses a number of listeners to automatically transit issue to another status. If you don't want this happening you'll need to change the workflow or create your own. You might want to test this in a Test Environment first. Best regards, Peter

I have disable all notification on my project, and tested different workflow (even the simpliest just with Step open), but my customer always get an email notifiying:

  • A new Comment
  • A new state "waiting for Customer"

Am I missing something?

Hi I would also like to take off the notification for status change.  Since the customer is receiving the comment by email they feel it's excessive to receive 2 email messages, one with the comment and one with jsut the status change.  Is there any way to disable this or request an feature that allows it?  I do not have directaccess to creating email templates.  I admin the interface but did not do the setup/install of workflow or templates.  

Thanks

Hi, Please see my issue and vote if its the same issue. Thanks https://jira.atlassian.com/browse/JSD-2009

Old question, but this was driving me nuts and I fixed it, so I figured I'd share how. (Note that in our case, the issue was sending unnecessary notifications internally, not to customers – an extra email notifying us of every status change whenever somebody replied to a comment. We already get notified of the comment, so we don't really need another entire email about the automatic status change.)

We use JIRA for both service desk and bug tracking. I didn't want to mess with the notification scheme for bug tracking, so first I had to make a copy to use just for service desk:

  1. Go to Administration > Issues
  2. Click Notification Schemes
  3. Click Copy next to the Default Scheme
  4. Rename the copy something nice, like "Service Desk Notification Scheme"

Then I had to set which notifications would be sent.

  1. Go to Project Settings for your JIRA Service Desk project
  2. Click Notifications
  3. Click the button for Actions > Edit Notifications
  4. Delete all notifications under "Generic Event"

Since resolving an issue has its own notification setting, you will still get a notification when things are resolved, but not for every single automatic status change. 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

990 views 2 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you