Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA openSprints () function not working

Hi,

I tried using sprint in openSprints () function but it is showing no issues found. But, when I remove this from the JQL and run my query I am able to see the issues in the current sprint, future sprint.

Can anyone help me out here?

1 answer

0 votes

Hi Ayush,

I checked using just the "Sprints in openSprints()" portion of the JQL, and its working without issue in my test instance, so I am wondering if there is some error in the logic occuring for the full query causing a conflict.

First, can you run the "Sprints in openSprints()" JQL by itself just to verify this portion is functioning as intended, and then can you provide the full query you are using so I can take a closer look.

Regards,
Earl

Hi Earl,

Thank you for the response. 

Sample Query that I am using - issues in (FET-1234, FET-7383) 

This is working fine.

But, when I am using issues in (FET-1234, FET-7383) AND Sprints in openSprints()

I am getting something like this(AttachmentScreenshot 2019-06-24 at 6.58.27 PM.png).

 

Can you help me out here?

Hi,

The error you are seeing: "Field or Filter does not exist or you do not have permission to view it" has a few different causes covered in the following KB article, and I would guess that the sprint fields is set to Hidden in the field configurations, check out the KB for some additional details at point 5 in the resolution section:

Regards,
Earl

Hi Ayush,

Do you have a custom field called Sprints? If you want the default field, this is a singular form.

So: in the JQL you are using Sprints in openSprints(), where it should be Sprint in openSprints().

Like Earl McCutcheon likes this

Hi Johan,

No, it is not a custom field and I tried using Singular as well as Plural form but it was not working till yesterday.

Though, it worked with Singular form today. Really don't know how this happened.

Thanks a lot!

I am getting: Unable to find JQL function 'openSprint()'

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

318 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you