Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,267
Community Members
 
Community Events
168
Community Groups

Setting up REST in Azure Data Factory Linked Service

Hello all,

I'm trying to connect to Jira Align via REST in Azure and I am having trouble setting up Azure Data Factory Linked Service .

I try Basic Authentication (as OAuth2 is not avialble with JA) and have tried username and password as well as varied versions of API Token, with or without "Bearer", with or without userxxxx| but I don't seem to get it to pass. All I get is "Rest call failed with client error, status code 401 Unauthorized, please check your activity settings."

I can  get them to work in Swagger and Postman so I know the API Token is working, but I just don't know how to configure them in Data Factory.

Any help would be appreciated.

1 answer

1 accepted

0 votes
Answer accepted

I got a reply from Atlassian and this works.

When setting up the Linked Account in Azure Data Factory to connect to Jira Align via REST API, and you use pretty much anything ......  it will show as connected but when you try to create a source connection in the CopyData activity, it will fail. 

So, going back to the Linked Service you are trying to create, firstly, rather than set it as Basic, set the Authentication Type : Anonymous

Now move down to the Auth Headers.  I then selected Authorization from the Name dropdown  and under Value dropdown I added  the string Bearer useryyy:|xxxxxxxxxxxxxxxxxxx with yyy being your User ID and xxxxxxx being your API Token (See User Menu>> Edit Profile >> API Token .

NOTE: You can add the string to your Key Vault as well and attach it

Now, when you then go to your CopyData Activity which is connected to this Linked Service, and you Preview Data ....... It works. 

So .... that's it.

Hello @Mark Northcott ,

 

I tried what you said , I put exactly Bearer useryyy:|xxxxxxxxxxxxxxxxxxx  and didn't work.  I guess that the pipe '|'  should be omitted.  So I tried like this.

Bearer user70999:xxxxxxxxxxxxxxxxxxxxxxxxxxx  but got no data in response , maybe there something else I need to take into consideration:

Screenshot_1.png

Thanks for the contribution,

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events