Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

HomeBrew Git update always breaks SourceTree

SourceTree is a great product, but there's one thing that is really annoying. I have Git installed using HomeBrew. When I update Git (because of a brew update), the next time I start SourceTree, I get the following error:

Screen Shot 2017-06-06 at 3.50.13 PM.pngSourceTree suddenly has no clue where my System Git is installed. This problem is probably caused by the fact that Homebrew uses symbolic links in /usr/local/bin that point to Git versions in the Cellar folder. 

Now every time Git is updated (which is quite often), I have to click away a few error dialogs and go to Preferences and reselect my System Git location.

It would be great if SourceTree could be a bit smarter in handling HomeBrew Git installations.

Thank you.

3 answers

Please fix this bug, it should be pretty straightforward. 🙏

I've been using SourceTree and Homebrew for years. Every time I run `brew upgrade`, I see a ton of errors in SourceTree and this is very demotivating. Steps to mitigate the errors are time-consuming and pretty dull – I have to open SourceTree Preferences, go to 'git' tab, press 'Use System Git', press 'OK', press 'Use System git-lfs`, press 'OK', close preferences and finally hit cmd+R in every opened SourceTree window. Doing so is necessary every couple of weeks, with every new git update coming from Homebrew.

As a developer who's primary IDE is VSCode, I'm beginning to think of using it as my git client every time error modals in SourceTree are thrown in my face 😞

I've got this problem, too. In my opinion SourceTree should be able to follow the symlink from /usr/local/bin/git

I figured out a manual but hopefully permanent fix.

If you manually edit the com.torusknot.SourceTreeNotMAS.plist file under ~/Library/Preferences/com.torusknot.SourceTreeNotMAS.plist.

set the gitCustomPath key to

/usr/local/bin/git

this will make it resolve properly on startup 

 

I believe the issue comes from the file selector and not something internal in sourcetree.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Training & Certification

Atlassian Cloud 101: Start quickly with free training

Free training for Jira, Confluence, and Jira Service Management Start faster and be more productive with Atlassian cloud products. Take the guess work out of where to begin, and gain confidence wi...

80 views 3 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you