Clone permissions

I recently created a private repository. From the given https link, I tried "git clone URL" command. It just cloned without prompting me for a password. Is this acceptable or am I missing something?

Thanks in advance,

M

 

4 answers

1 accepted

It turns out that, on the MAC that I was using, the password for Bitbucket is stored in the KeyRing. So it automatically logged in. Sorry about the imprudent question !

It depends.  Was it an http or an ssh URL?  Are you using Bitbucket Cloud, Bitbucket Server, or some other hosting for your remote repo?

Sorry, I forgot to mention. It is bitbucket-cloud and HTTPS. I have been using it for several years now and I have not noticed that it cloned without password prompt. The documentation clearly states that, private repositories cannot be cloned without proper permissions even with a valid URL. Is there some setting I am missing?

I'm not sure - I haven't used Cloud, only Server.  But that certainly sounds odd.  A clone request using http should always require a password unless the repo is configured to allow anonymous access.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Agility Beta

We've moved!

A note to all watchers that we've moved to a new community home... https://community.atlassian.com/t5/Agility/ct-p/agility Please update your notification subscriptions to keep across the ...

58 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you