Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,246
Community Members
 
Community Events
168
Community Groups

Unknown lifecycle phase "${mavenPluginName}=$mavenPluginName" Error while developing crucible plugin

We are trying to create a plugin for the crucible. This plugin enables every comment to be marked as a defect.

 

After running atlas-create-crowd-plugin-module i ran this "atlas-mvn package" and  getting below error:

Unknown lifecycle phase "${mavenPluginName}=$mavenPluginName". You must specify a valid lifecycle phase or a goal in the format <plugin-prefix>:<goal> or <plugin-group-id>:<plugin-artifact-id>[:<plugin-version>]:<goal>. Available lifecycle phases are: validate, initialize, generate-sources, process-sources, generate-resources, process-resources, compile, process-classes, generate-test-sources, process-test-sources, generate-test-resources, process-test-resources, test-compile, process-test-classes, test, prepare-package, package, pre-integration-test, integration-test, post-integration-test, verify, install, deploy, pre-clean, clean, post-clean, pre-site, site, post-site, site-deploy. -> [Help 1].

I am new to plugin development. Any help would be appreciated.

 

2 answers

I think this is helpful for your problem:
* go to atlassian-plugin-sdk -> bin->atlas-mvn.bat file.
* replace call set MVN_COMMAND=%%MVN_COMMAND:${mavenPluginName}=%MVN_PLUGIN%%% to call set MVN_COMMAND=%%MVN_COMMAND:%%

this worked for me Thanks!

thanks,also worked for me

Worked for me too!

This is resolved in another answer, please refer to see two changes that needs to be

https://community.atlassian.com/t5/Jira-questions/Unknown-lifecycle-phase-error/qaq-p/1006922

If this resolve your issue, please accept this answer

@Gaurav TomarPlease NEVER accept this answer. The only acceptable answer is for Atlassian to fix their product that has been broken for over 2 years.

 

Please vote for, watch, and comment on https://ecosystem.atlassian.net/browse/ATLASSDK-93

Like # people like this

The above-mentioned issue has been marked as resolved, but still occurs on latest 8.0.16 release.

https://ecosystem.atlassian.net/browse/ATLASSDK-179 issue marks it as resolved and will be released on 8.0.17.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events