Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,394
Community Members
 
Community Events
176
Community Groups

Setting SVN permissions fails

Hi !

When we configure a project, if we try to change the permissions for which groups has the right to commit, as soon as we remove the developers group, no one can commit anymore.

Anyone experienced that ?

Thanks !

Steve

1 answer

I just tried. I have a group called "writers" and a user named "writer" who was a member of that group. The "writer" user is licensed for FishEye (as well, as it happens, JIRA and Confluence). The user must be licensed for FishEye to use SVN.

I created a new project. I went to the Project administration and edited the FishEye permissions (/secure/admin/ProjectRepositoryPermissions.jspa?repositoryKey=xxx), added the "writers" group to the Commit panel, and removed the "developers" group.

I checked out SVN, added a file, committed it, and it worked.

You may need to wait a few minutes for the permissions to synchronize through the cache between FishEye and the SVN server, but generally it's immediate.

Hope this helps.

And as soon as I readd the developers group, it works again...

Hi Josh, thanks for the quick answer !

I just tried again, the same procedure, and when I do so (removed developers + administrators) and add a new custom group, I get the error message, it's a 403 from the repo...

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events