Fisheye will not connect to Bitbucket server

Hi,

 

I am currently configuring Fisheye+Crucible and found out that Fisheye can see the repository of BitBucket but cannot create a connection. I simply went to the BitBucket server repository tab and clicked add. This can now be seen in the native repository after. I then clicked a repository and tried test connection which resulted in this error:

Could not find SSH binary on the system path. See https://confluence.atlassian.com/display/FISHEYE/Authentication

Error testing connection.
Could not find SSH binary on the system path. See https://confluence.atlassian.com/display/FISHEYE/Authentication
at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:226)
at com.atlassian.fecru.security.SshWrapper.<init>(SshWrapper.java:19)
at com.atlassian.fisheye.dvcs.client.DvcsProcessFactory$DvcsProcessBuilder.initProcessBuilder(DvcsProcessFactory.java:92)
at com.atlassian.fisheye.git.client.GitProcessFactory$GitProcessBuilder.initProcessBuilder(GitProcessFactory.java:34)
at com.atlassian.fisheye.dvcs.client.DvcsProcessFactory$DvcsProcessBuilder.build(DvcsProcessFactory.java:76)

Connection failed.

 

Environment:

Fisheye+Curcible and Bitbucket hosted on the same server.

 

Because on this error I tried searching for solutions but was not able to resolve it.

1st possible solution : added environmental variables to path. (C:\Program Files\Git\bin;C:\Program Files\Git\cmd)

Source:

1. https://confluence.atlassian.com/fishkb/fisheye-does-not-sync-an-added-repository-from-bitbucket-server-on-windows-800298552.html

2. https://community.atlassian.com/t5/Fisheye-Crucible-questions/Attempting-to-Connect-to-Stash-from-Crucible/qaq-p/188474

2nd possible solution : went to admin -> server and added the C:\Program Files\Git\bin\git.exe

Source: https://confluence.atlassian.com/fisheye/git-client-298976877.html

 

Help would be very much appreciated. Thanks in advance.

 

1 answer

1 accepted

1 vote

Hi Marvin,

The error is caused by the fact that the OpenSSH binary is not accessible on your system for Fisheye to successfully connect and clone the repositories.

On Windows SSH is not available by default and will need to be manually installed, the way we recommend proceeding is to download and install [Git for Windows|https://git-for-windows.github.io/], as this includes OpenSSH. Be careful about the options you choose during the install:


- When asked how to adjust your PATH environment, select the option '+Run Git and included Unix tool from the Windows Command prompt+'. This will ensure that Git and its associated tools (including OPENSSH) are available to the FishEye server via the PATH environment variable.


- When asked for the SSH executable, select the option '+Use OpenSSH+'. The FishEye server doesn't work with alternatives like TortoiseHg or Putty.

Can you please confirm that this has been done? If not, please install Git once more with the selected options and let us know if this helped.

 

I hope this information is helpful!

Hi Nathaniel,

 

You are correct. This solved the problem. It wasn't a PATH issue but an installation issue where I most probably did not install open ssh. After running the installer again and making sure that the openssh was ticked and not Putty or TortoiseHg, Fisheye can now access the Bitbucket repository.

 

Thank you very much.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

64 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you