It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

update any plugins got an error that Problem accessing add-on file at <pluginName>

When I want to update my plugins,every update actions will got this feedback:Problem accessing add-on file at <pluginName>

 

please help me reslove it。(an chinese subscriber)

 

my email:952045609@qq.com,

I download the <Confluence_support_2019-12-03-12-46-33> file,but there is no ways for upload,if it's need,concact with me thanks!

错误截图.png

 

 

2 answers

0 votes

Hello @十七,

Nice to meet you! Welcome to Atlassian Community.

If you are located in China, it's likely that the firewall is blocking connections. You will want to go through the procedure below to determine what exactly is being blocked.

You can also view the page in Developer Tools (Network tab) in your browser. It will mark the things being blocked in red so you can know what you need access to.

In order to upload apps to your instance manually, you want to click Upload App in the top right-hand corner of that screen.

CleanShot 2019-12-05 at 10.24.21.png

Let me know if you have any trouble.

Regards,

Shannon

Thanks for your suggestion!

 

I checked my firewall,ping it's OK。

 

Before I use http,I can't even upload application form my local environment with installation eazyBI。when I change my config to https,now I can install it from this way。

 

But,I also can't use convenient online service。

 

In fact, when I first started using confluence, I was able to install the plug-in online. Suddenly one day, I couldn't update it. I don't know what the specific reason was, which puzzled me.

@十七,

To confirm, after you made the change to https, it started working? Can you let me know what config change you made exactly?

If you're behind a proxy, it could be that the proxy was blocking insecure traffic. Have you brought this to your network admin, if this is not yourself? They might be able to tell you the reason for that.

Regards,

Shannon 

use https,As the official tells,nothing special。

 

I use it for myself,I'm also the netword admin。

Hello @十七,

Thank you for confirming with me that you are not using a proxy.

I'm still a bit unclear on your exact situation. Here's how I understand it:

  1. You mentioned your firewall, and that you pinged it, and everything is okay. I'm not sure what you mean by this. Can you help to explain that? 
  2. Does this issue occur outside of your firewall as well as behind your firewall?
  3. You were using http before, and were not able to use UPM to update your plugins.
  4. You switched to https, and now everything is working?

I look forward to your response.

Regards,

Shannon

0 votes
Ollie_Guan Community Leader Apr 02, 2020

Hi @十七 ,

Welcome to the community!

Join your city’s online group to keep the conversation flowing.

https://ace.atlassian.com/shanghai/

https://ace.atlassian.com/beijing/

https://ace.atlassian.com/hang-zhou/

https://ace.atlassian.com/shen-zhen/

https://ace.atlassian.com/guang-zhou/

Feel free to add my Wechat(guanqun1982) and join ACE in China.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

297 views 9 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you