twiki to confluence migration

I am just trying to do a trial of twiki to confluence migration using UWC.

 

UserList is first page to migration from Twiki, but it fails with UWC log saying

 

2018-01-20 17:19:34,603 INFO [Thread-7] - Starting conversion.
2018-01-20 17:19:34,604 INFO [Thread-7] - Initializing Converters...
2018-01-20 17:19:34,635 INFO [Thread-7] - Initializing Pages...
2018-01-20 17:19:34,663 INFO [Thread-7] - Converting pages...
2018-01-20 17:19:34,663 INFO [Thread-7] - -------------------------------------
2018-01-20 17:19:34,663 INFO [Thread-7] - converting page file: UserList_two.txt
2018-01-20 17:19:34,682 INFO [Thread-7] - no attachment files found in directory: C:\Users\chauhahi\Downloads\twiki\TWiki-6.0.0\pub\Main\UserList_two
2018-01-20 17:19:34,728 INFO [Thread-7] - Converting Spacenames - complete
2018-01-20 17:19:34,728 INFO [Thread-7] - time to convert 65ms
2018-01-20 17:19:34,728 INFO [Thread-7] - ::: total time to convert files: 0 seconds.
2018-01-20 17:19:34,728 INFO [Thread-7] - Building Hierarchy.
2018-01-20 17:19:34,744 INFO [Thread-7] - Uploading Pages to Confluence...
2018-01-20 17:19:34,775 ERROR [Thread-7] - REMOTE_API_ERROR: Could not transform wiki content in page: 'UserList_two' from markup to xhtml.
2018-01-20 17:19:35,882 INFO [Thread-7] - Uploaded 1 out of 1 pages.
2018-01-20 17:19:35,882 INFO [Thread-7] - Conversion Complete
2018-01-20 17:19:35,884 ERROR [Thread-7] -
Conversion Status... UNEXPECTED_ERROR

 

The converted page is uploaded to confluence, but not correctly.  

Since this had been tried by many time in past by other. So I would appreciate if anyone can guide me  to solve this issue.

 

2018-01-20_17-21-28.gif

1 answer

If I remember correctly, the UWC is deprecated, due to many changes in the Confluence database/API. It is not an out of the box solution, but more of starting point to mod/update to the current API.

It is correct that UWC is deprecated, But I think must have been working to migrate the twiki content to confluence 5.x

It has been deprecated for some time, so would have to be an early version 5.x release (certainly before they changed the database).

The easiest thing to do is spin up an early 5.x installation and see if it works. The official possition is that support ended at 4.3.7

https://confluence.atlassian.com/doc/importing-content-from-another-wiki-690847783.html

This post seems to indicate it worked with 5.5.7

https://blog.valiantys.com/en/confluence-en/universal-wiki-converter-transfer-wiki-content-confluence

 

I know when my team did a conversion for a client, it did involve a fair amount of work to get it working reliably.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

967 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you