Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

single space vs double space line formatting

a team member began a list of links (to internal pages) - I needed to append the list. The list started out single spaced but every time I hit the Enter key my text is double spaced, is there a way to edit this?

5 answers

1 accepted

7 votes
Answer accepted

Check what current format is set. Is it in a "Heading"? "Paragraphed"? 

Thanks for the reply - I seem to be in paragraph, there are 6 levels of headings, a preformatted, and a quote mode, what mode should I be in?

The Paragraph format should do the trick. Alternatively, instead of pressing ENTER at the end of a line, press "SHIFT + ENTER" to disable all sorts of formatting.

Like # people like this

not sure why paragraph mode is giving me doubt-spacing; but SHIFT + Enter works like a charm - thank you very much. Some boards allow assigning Kudos - don't see that here but you earned them, thanks again - lmd2

Like Caleb_Castro likes this

Ha! Glad to help! :) You can just click "Accept Answer" here.

Like Caleb_Castro likes this

Here is a way

Use a macro called "no format"
So be where you want to paste in the confluence document. Type a left curly bracket (uppercase the left square bracket), then start typing no format. Select the "no format" option. This creates a box that when you paste single spaced text it stays single spaced in the box.

My Product Owner was looking for a way to get tighter spacing and found the {no format macro quite useful. Thanks!

Is this seriously how to change the spacing? Create a macro or use keystroke combinations? This is like Wordstar from 1988. This should be as easy as a menu bar button or option from a dropdown, not some archaic way of changing things.

There's nothing more annoying than performing a copy and paste into this relic than to have to go all the way through it and change the spacing because by default it wants to double space everything.

100% agreed. Why the HELL would you assume someone wants double spaces every time they hit enter - that is absolutely f-ing insane. I really really hate it. 

Like # people like this

Absolutely agreed, here too.  Mine always seems to happen when pasting into a code block, which is supposed to be all preformatted text.  Confluence will:

1) change the pasted text to paragraph format (!?!@!?)

2) screw up all the rest of the code block with wide line spacing.

This needs to be better resolved.  It's been a decade, now.  It makes me want to keep all of my pages in Notepad++ or something, instead of constantly fighting this.

Like Deleted user likes this

I completely agree as well. This is the greatest annoyance I have with all of their products. What world defaults to double spacing?

So we are back in the world when software houses produced what they thought the user should need and did not listen to what they actually needed.

Moreover, when many users complain about this they open tickets and then just close them giving only weak excuses as to why.

Offering the solution of "Shift + Return" is pathetic!

For those who are interested, it is more efficient (which doesn't mean it is efficient - just less of a pain) to type your test in Notepad and paste into Jira. That retains single line spacing and single spacing for carriage returns.

 

So, I have since discovered that if you have the same process as I do;  copy from email and paste, you can right mouse click and “Paste as Plain Text” and the double return is not added.

Pasting into Notepad, then into Jira does eliminate the double spacing, thanks.   Pretty surprising that this has yet to be resolved by Jira after so many years. 

Like Cheryl J likes this

Ivan, thank you.

When typing shift enter does single spacing, where enter does double spacing. This works in word and wordpad also.

 

Here is a way to paste single spacing

Use a macro called "no format"
So be where you want to paste in the confluence document. Type a left curly bracket (uppercase the left square bracket), then start typing no format. Select the "no format" option. This creates a box that when you paste single spaced text it stays single spaced in the box

Tried {no format... in Confluence when using Meeting Notes but did not get a "no format" option.

Like Nat likes this

I did not get "no format.." either

so many year pass...
the spacing design mistake 
<br>
<br>
<br>
just fu*k shift+enter !!!!!!!!!!!!!!!!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

408 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you