"Edit document" button is disable(Office Connector)

Hi users,

I have a version 3.3.1 of Confluence Installed in my company and exists a user with a problem when he tries edit a document using office plugin.

"edit Document" button is shown disabled, I would like to know why happens this event.

The user has permission to Edit page and Add Attachments in Space.

Best Regards

Pedro Sousa

5 answers

1 accepted

This widget could not be displayed.

Pedro,

I would encourage you to work with the group that maintains your systems and see if they can adjust the configuration on one machine or test this option for you or provide an additional browser option for you.

We have learned over time that Internet Explorer on some sites and some web applications needs this setting. In practice what we recommend is having alternative browsers available so an individual can switch if needed to another browser.

In general we have found FireFox to be the most consistent behavior across web sites and applications. I hate to say that because I am a Chrome user, but I have fewer problems with FireFox than any other browser.

Hi Chuck this problem occurs only with one user. The button is shown disabled for him. Another users can edit documents using office conector. Then the problem is not the browser, is the user, but I don't know how to solve the problem. I've tried remove the user from the group and re-add, but it's unsuccessfully.
This widget could not be displayed.

Hi Pedro!

Check if the user have MS Office and or Open Office properly installed. Usually this is the problem.

But just in case, also check if the Webdav Plugin is properly enabled. You can check this on Confluence Admin > Plugins.

This widget could not be displayed.

We found in Confluence 3.4.9 that Internet Explorer needed to be set to Compatibility mode for some features to work, perhaps this is a similar situation.

Typically this is found under the Tools menu.

Hi Chuck

Im My Company, the option "Compatibility mode" was disabled of browsers. I don't able to active this option beacuse I am not Administrator of my Computer :(

This widget could not be displayed.

Hi Bruna,

This user has Microsoft Office 2003 installed in his computer and his browser is IE8

This widget could not be displayed.

Someone help me?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

136 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you