never ending "downloading and installing..." in UPM

Andrei [errno] Community Champion Jul 31, 2013

tried to upload a plugin (new version of "Share page") and see a progress bar that is stuck @ about 85%.

Page refresh brings the progress bar back to about 50% -> goes to 85% and is stuck again. No errors in the logs. Will plan to restart the system after EOB, but am curious - has anyone experienced anything like that?

6 answers

1 accepted

1 vote
Andrei [errno] Community Champion Aug 26, 2013

it seems that I can trace the problem back to installed "groovy-2.1.3.1" runtime. https://marketplace.atlassian.com/plugins/org.codehaus.groovy.groovy-all-atlassianplugin

I have been disabling plugins one by one until I could reproduce the "hanging" of the UPM.
Groovy is an OSGi bundle, so it may affect UPM in some way

Hey,

Assuming that you're using MySQL, you might be facing this problem, related exclusive with MySQL, that is max_allowed_packet that is set too low for Confluence.

You might want to check our documentation to fix it:

https://confluence.atlassian.com/display/CONFKB/Exceeds+Max+Allowed+Packet+for+MySQL

Cheers,

WZ

Andrei [errno] Community Champion Jul 31, 2013

it is indeed MySQL - thanks for the tip. I will check into that

Andrei [errno] Community Champion Aug 22, 2013

after setting max_allowed_packet to 34M the same problem is still observed...

Also, ensure that the URL you use to access Confluence via the browser match the Base URL configured in Confluence Admin > General Configurations.

Andrei [errno] Community Champion Jul 31, 2013

confirmed = and it is the base url. thanks

How are you trying to install the plugin? If you are installing from the built in marketplace or are you donlaoding it and installed manually? Anything change after your restart?

Andrei [errno] Community Champion Aug 25, 2013

both manual uploads and through UPM had issues - so I removed all plugins and restarted Confluence + installed plugins 1-by-1 => I see errors relating to Adaptavist PLM plugin (their licensing manager) - disabled that. Plugins update fine now.

Weird.. never had issues with Adaptavist products before :(

I have same problem installing Composition addon.

the screen "downloading and installing" never finishes.

It has some timeout, or I need to restart confluence? 

Hello,

I had the same problem today with a Confluence 5.8.15 trying to install a SAML plugin.

Moreover, this was blocking all access to the plugin management pages since the "Downloading ... Installing..." page was showing up each time I tried to access those pages.

This is what I did to resolve the issue :

  1.  go to <confluence-home> and rename the file temp/<plugin>.jar downloaded to temp/<plugin>.jar-down
  2. restart confluence
  3. log back in confluence (at this step I wasn't blocked anymore by the screen)
  4. Update the “Atlassian Universal Plugin Manager Plugin” to the latest version
    1. refresh the page as suggested by the plugin install
  5. Find the plugin again and installing it successfully.


Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

1,919 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you