left navigation link goes to wrong page

This question is in reference to Atlassian Documentation: Working with Links

I have a landing page that is missing. I have checked the trash and do not see it there. I have checked other trees in the left navigation and do not see it there. The left navigation link for that page points to a blank page in another tree. How can I fix this?

5 answers

This widget could not be displayed.

I'm not sure

But have you checked Browse>Space Operations - there are options there for Orphaned and Undefined pages which might need to be cleaned up.

This widget could not be displayed.

Hi Rodney, Yes I checked both of those it's not there either. I appreciate your suggestion. Any other thoughts?

This widget could not be displayed.

Nope!  I'm out of simple ideas .... does the page directory need to be rebuilt/refreshed by the system administrator (if that sort of thing can be done ..???)

To be clear for others to think on :

when you are in Space "A", there is a page shown in the left hand navigation tree.
That means it must also be listed in Browse>Pages and the Tree view and appears underneath the Home page somewhere?

But when you click on the page link it goes to a blank page within Space A? i.e. it is a page with no title and no text but a "real" page?

Or do you mean it opens like when you click Create>Blank Page

How do the direct URLs compare of the starting page and the resulting page?

It might help others spot what is going on if you can post a screen capture of the navigation pane and the blank page and its URL (most PC's have a tool called Snipping Tool to capture selected areas of the screen)

This widget could not be displayed.

I have a left vertical navigation. I am selecting a top level navigation button which should render a page in the same spot in the tree with it's content. For this particular page it now points to a page with the same title, but under a completely different parent. The content is blank as well. Both of these links are in the same space (A).

 

There is a third page with the same title as well but it is in space B and not related to this problem as far as I can tell.

This widget could not be displayed.

Confluence doesn't allow two pages in the same Space to have the same title so for some reason it is not seeing the correct Parent-Child relationship.

Can you post a screen shot of the navigation tree to help explain?  Also of the Browse>Pages tree view and alphabetical view?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

569 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you