confluence create does not pull templates

Hi all,

I upgraded my test server to 5.7.1 in preparation for the upgrade of the live server and now when I try to create a new page in any space I get a spinning wheel "loading" and never loads (I even left it running all night still loading the next morning) and the following error in my log:

net.sf.hibernate.ObjectNotFoundException: No row with the given identifier exists: 61898755, of class: com.atlassian.confluence.spaces.Space

Anyone know what went wrong? I tried a re-index but it didn't help.

2 answers

1 accepted

This widget could not be displayed.

select * FROM CONTENT WHERE SPACEID = '61898755';

with the mouse click select all, right delete rows.

And the problem went away.   Thanks!

Shoot! It started again, same error

The entries in the database came back. I re-synchronize (rsync) the home dir from the live server to the test server and re upgraded and this resolved it. That is why it is a test server :-)

This widget could not be displayed.

Hello Robert, it appears that the application is having troubles while retrieving data from a label. You can use the following queries to remove any orphanated references, note to have a DB snapshot ready before running any queries against the dataset.

First being to check scope, second to remove reference, third to find additional offenders that may persist harming Confluence. :-)

select * from content_label;


delete from content_label where labelid=61898755;
 
select * from content_label where labelid not in (select labelid from label)

 

 

Interestingly, there were no labels with labelid of '61898755' when I did a select * from CONTENT_LABEL; When I did the delete from I got 0 rows affected.

So the problem still exists

I did a search of all tables in the database and 61898755 is a space id. Maybe a deleted or rogue space?

K I know what happened now, I got a list of all the titles. What happened was I did a database export from the live server and a database import to the staged server. The live server had some a space that was deleted, and when the database got imported it must have had residue of that lost space. How do I remove that content? I tried delete FROM conf.CONTENT WHERE SPACEID = '61898755'; but that did not work as it failed foreign key constraint.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

349 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you