It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

.action pages not loading

Any page that ends in .action is not loading on my self-hosted Confluence instance. For example, I can't log in because login.action doesn't load. I can't search because dosearchsite.action doesn't load. Any help would be appreciated!

1 answer

1 vote

Hi @Christopher Taverna ,

I would start by reviewing when this issue started happening, for instance:

  • have you restarted Confluence and only after that .action stopped working?
  • have you restarted your proxy and only after that .action stopped working?

This you give you some direction on where the problem may be. Furthermore, does the same issue happens if you bypass proxy altogether? It could be a URL rewriting instruction in your Apache, Nginx,... that could be preventing you from accessing those pages, e.g https://confluence.atlassian.com/doc/using-mod_rewrite-to-modify-confluence-urls-226165314.html

Kind regards,
Rafael

I noticed it wasn't loading, restarting the server did not help. Not sure what you mean by proxy... Thank you.

Hi @Christopher Taverna ,

I noticed it wasn't loading, restarting the server did not help.

You need to identify when the issue started happening and which changes may have contributed to the issue you are experiencing.

For instance (not the restart in your statement but the one before)

  • Before the restart you have mentioned, when was the last Confluence restart?
  • Have you or anyone done changes to any Confluence configuration files before the restart?
  • What was the reason for restarting Confluence?

Let's say you access your Confluence instance by typing in http://192.168.1.2:8090 or http://localhost:8090 on your web browser. By doing so, you would be bypassing a proxy that could be Apache, Nginx, ... where it basically translate that IP:PortNumber into something more meaningful, e.g http://my.confluence.instance

Therefore, if you are accessing Confluence without providing a port number in your web browser, there are great chances you have Apache, Nginx or something else translating the IP:PortNumber into a ServerName.

If you go to the server where Confluence is installed, search for <confluence-install>/conf/server.xml. Open this file and search for <Connector /> tag (you may have more than one):

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<Connector port="8090" ...

In the above, the connector describes Confluence will be listening on port number 8090. Therefore, in the same server where Confluence is running, you could open a web browser and hit http://localhost:8090

If you have any proxy property in the same connector (e.g proxyName, proxyPort...), then you would have to:

  • find which proxy (e.g Apache, Nginx) is interfacing the proxy property defined in your Connector. In there, you can review if there are any rewrite instructions to HTTP requests
  • (if you still unsure what a proxy is or where it is located), create a new connector, so you can guarantee you will access Confluence within its Tomcat configuration only:
    <Connector port="8091" 
    connectionTimeout="20000"
    redirectPort="8443"
    maxThreads="48"
    minSpareThreads="10"
    enableLookups="false"
    acceptCount="10"
    debug="0"
    URIEncoding="UTF-8"
    protocol="org.apache.coyote.http11.Http11NioProtocol" />
    With the connector above in place, restart Confluence so changes can be applied and access Confluence by typing in http://localhost:8091 (from server where Confluence is installed) http://IP_ADDRESS:8091 (replacing IP_ADDRESS with ip address in which you can access Confluence from your laptop).

    Port number 8091 must be open in the server. Otherwise, replace 8091 with a port number that is open and above the existent <Connector port="..." in original connector.

    If you continue on experiencing issues with .action, than we can assume the issue is in Confluence configuration, as you may have changed any of the following files:
    - <confluence-install>/conf/web.xml
    - <confluence-install>/confluence/WEB-INF/decorators.xml
    - <confluence-install>/confluence/WEB-INF/urlrewrite.xml
    - <confluence-install>/confluence/WEB-INF/web.xml

Hope the above helps.

Kind regards;
Rafael

Thank you. I have tried from localhost and it still doesn't work. No changes have been made to the configuration. I only restarted to see if that made the issue go away. It is using the apache protocol referenced above. I know it was working last week, and no changes were made since then. I noticed it wasn't working today. 

Hi @Christopher Taverna ,

Is it only you experiencing the issue or other users are facing the same problem?

Have you tried different web browsers?

When restarting Confluence, have you restarted with the same user Confluence was originally running?

If you continue on experiencing issues, I would suggest you on raising as support request with Atlassian on https://support.atlassian.com

You will be able to provide them with more information than here in Community (eg logs, confia files)

Kind regards,

Rafael

Thank you! I can't log in, (login.action doesn't load) so this is with anonymous access. Yes, I've tried different browsers and other people have reported the issue as well. I will attempt to contact support.

Support told me to go to the community since this instance is under a starter license. Any additional ideas would be appreciated. Thank you!

Also, I checked the files referenced and none have been edited in months. This problem first occurred sometime between 9/20-9/25. Thank you!

Hi @Christopher Taverna ,

Could you please share some if not all of the following information:

  • Confluence version you are running
  • URL used to access Confluence
  • Operational System Confluence is running on

If you go to the server where Confluence is running, what happens when you run cURL command against the URL used to access Confluence appending /login.action ?

curl -k -v http://localhost:8090/login.action
* Trying 127.0.0.1...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 8090 (#0)
> GET /login.action HTTP/1.1
> Host: localhost:8090
> User-Agent: curl/7.54.0
> Accept: */*
>
< HTTP/1.1 200
< X-ASEN: SEN-L1267378
< Cache-Control: no-cache, must-revalidate
< Expires: Thu, 01 Jan 1970 00:00:00 GMT
< X-Confluence-Request-Time: 1569853326575
< Set-Cookie: JSESSIONID=B5F26BD9662AEE3CD9F1A161D7656212; Path=/; HttpOnly
< X-XSS-Protection: 1; mode=block
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< Content-Security-Policy: frame-ancestors 'self'
< X-Accel-Buffering: no
< Content-Type: text/html;charset=UTF-8
< Transfer-Encoding: chunked
< Date: Mon, 30 Sep 2019 14:22:06 GMT
<
<!DOCTYPE html>
<html>
<head>
<title>Log In - Confluence</title>
...

Since you mentioned "I can't log in, (login.action doesn't load) so this is with anonymous access.", what happens when you request login.action ?

Please, notice the example above is using http://locahost:8090 as Confluence Base URL. Yours may be different, so do the necessary changes by replacing the URL when issuing the command.

Last but not least, have you checked Confluence logs for errors during 9/20-9/25?

Kind regards,
Rafael

Version I believe is 6.15.4 (I can't login to look at it, but that's what my other instance is and they should be identical - that one is working fine BTW).

https://my.public.domain

Windows Server 2016

I just get a blank page when trying to login or search.

Yes, I have checked the logs, today this showed up which may be helpful:

2019-09-30 10:09:34,705 ERROR [https-jsse-nio-443-exec-20] [[Standalone].[localhost].[/].[file-server]] log Servlet.service() for servlet [file-server] threw exception
-- referer: https://my.public.domain/dosearchsite.action | url: /s/e0fd7f4ea8576e26442db715a0a0ccb3-CDN/en_US/8100/b0984b7297905b7c7bd946458f753ce0130bfc8c/acea1d81b0a6c3e65c696712496c7eaf/_/download/contextbatch/css/_super/batch.css | traceId: 99865ca747787ef8 | userName: anonymous
java.lang.RuntimeException: org.apache.catalina.connector.ClientAbortException: java.io.IOException: An established connection was aborted by the software in your host machine

 

I can run curl through PowerShell, but -k is not recognized. Running without it yields: 

PS C:\> curl -v https://my.public.domain/login.action
VERBOSE: GET https://my.public.domain/login.action with 0-byte payload
VERBOSE: received -1-byte response of content type text/html;charset=UTF-8


StatusCode : 200
StatusDescription :
Content :
<!DOCTYPE html>
<html>
<head>
<title>Log In - Policy Library</title>

 

 

 

 


...
RawContent : HTTP/1.1 200
X-ASEN: SEN-10340725
X-Confluence-Request-Time: 1569854199343
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
Content-Security-Policy: f...
Forms : {}
Headers : {[X-ASEN, SEN-10340725], [X-Confluence-Request-Time, 1569854199343], [X-XSS-Protection, 1;
mode=block], [X-Content-Type-Options, nosniff]...}
Images : {}
InputFields : {}
Links : {}
ParsedHtml : System.__ComObject
RawContentLength : 35420

 

Thank you!

Hi @Christopher Taverna ,

Based on the above, it seems you have a web server running, in which is proxying your requests to https://my.public.domain Unless you have only this website serving on port 443 on your network.

The org.apache.catalina.connector.ClientAbortException means that a user requested something from a web browser (e.g dosearchsite.action) and before Confluence processed the request, the same user visited another page or canceled the request. So the ERROR log you have mentioned is not what you should be looking at, I am afraid.

The property -k is used to surpass SSL certificate when running cURL command on Linux OS. But since you have a valid and certified SSL certificate, this parameter is not needed as I can also see the page by accessing the domain https://my.public.domain.

Furthermore, I am able to visit https://my.public.domain/pages/viewpage.action?pageId=10158472 .

So the issue relates to only some of the pages where .action is called.

When visiting this page with Google Chrome Development Panel enabled, we can notice there are some issues related to Synchrony:

{"type":"missing-token","message":"Missing token"}

However, without knowing the ERROR thrown in Confluence logs I cannot provide you with a more precise guidance on what the issue may be. Anyhow, please find in this link something related to the JSON response from above:

https://community.atlassian.com/t5/Confluence-questions/How-to-setup-synchrony-within-proxy-environment/qaq-p/743669

Please, revisited the logs checking for Synchrony errors.

You can find more information on https://confluence.atlassian.com/confkb/collaborative-editing-and-synchrony-troubleshooting-858584399.html, more specifically on:

Please, let us know if you want to sanitise Confluence's Base URL (https://my.public.domain) and remove the screenshot I have provided in this comment, so the information can become anonymous.

If you continue on experiencing issues and prefer to have a more tailored support, disclaiming more information that you could here in the Atlassian Community, please notice that you can contact one of the Atlassian Partners (3rd party value added resellers) who offer a wide range of professional services, training, customizations and paid support. More information on Atlassian Support Offerings

Hope the information provided helps.

Kind regards,
Rafael

Thank you. Yes, please sanitize. 

I don't understand how this suddenly started happening, nor do I see how to resolve this issue. I'll keep looking, thanks!

Hi @Christopher Taverna ,

I have replaced the URLs with my.public.domain and removed the screenshot from comment as suggested.

Regarding on the issue, you could start by checking if Synchrony is working as expected - How to check the status of Synchrony for Confluence Data Center.

Kind regards,
Rafael

Thank you! Does it matter that I am not running a Data Center install? It is a single server.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

314 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you