Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Your URL doesn't match

I am using the confluence on the port 8090. I connected wiki.pystock.net (sub-domain) to this port by using the apache2 virtual host. (/etc/apache2/apache2.conf)

 

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
<VirtualHost *:80>
ServerName wiki.pystock.net
ProxyPass / http://localhost:8090/
ProxyPassReverse / http://localhost:8090/
</VirtualHost>

 

I also modified the conf/server.xml . The last one line is added. 

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
                maxThreads="48" minSpareThreads="10"
                enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
                protocol="org.apache.coyote.http11.Http11NioProtocol"
                proxyName="http://wiki.pystock.net" proxyPort="80"/>

 

Everything works well. But there is a message of "Your URL doesn't match". 

Is there any way to turn off the message "Your URL doesn't match" ?

As you can see, setting URL and accessing URL is same as below. 

image2017-3-20 17:37:20.png

1 answer

This means that your instance is still using wiki.pystock as its base URL. 
You might have restored an xml backup in which the base URL was wiki.pystock.

You can chose to Update Base URL to rectify this.  

You can also check the base url of your instance by going into System Info (g+g system info
there you can see what's the actual base url your instance is running on.  

Thank you for your answer. 

I checked Server Base URL as below: (View System Information in confluence)

image2017-3-21 8:56:3.png

 

I also set the same Server Base URL in the General configuration as below:

image2017-3-21 8:57:7.png

 

How can I solve this problem?

I am having the same issue after upgrading to 6.1.  Did you ever figure this out?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence Cloud

Please tell us how you use Confluence space settings

👋 Hi there, a few of us at Atlassian would love to learn about how you use "space settings" functionality in Confluence. A facelift to the space settings is long overdue and we want to start with im...

166 views 5 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you