Widget Connector not working with YouTube but working with Vimeo

Gang,

We are having this non-critical but still annoying issue with Widget Connector whereby Vimeo links preview and insert into a confluence page just fine, but when we enter YouTube links, the preview works but the insert action returns nothing.  So we literally cannot even get the entry to register into the confluence page...

 

It's been suggested that our NAT configuration is messed up, but I have a difficult time understanding why Vimeo links work and YouTube links don't.  We are on a Windows environment and I have tried this with IE, Chrome and Firefox and the behavior is the same on all 3.  I can open up both YouTube and Vimeo links just fine in all 3 browsers so the only issue seems to be with the Widget Connector.  Any ideas on how I can properly trouble-shoot this to find the cause?

 

thanks for any tips or advice! --GY

7 answers

Hello!

Same issue here, do you have any follow-up ?

We are experiencing the same issue. Can use Vimeo links but not YouTube. Any solutions?

We found that using the full YouTube URL instead of the one provided under "Share" works with the Widget Connector.

After much discussion between Atlassian support and our internal systems team we were not able to resolve the issue.  I'm bummed I can't offer any advice...

Exact same issue - Vimeo working, Youtube does not Insert anything. We are hosting our own Confluence, so not sure if that is related. Hope there is a solution - users not happy!

I'm having the exact same issue with Confluence 5.2. Thw Widget Connector doesn't embed the video at all. It does nothing. I tried every fix inluding using the long URL, making sure t= isn't in the URL, making sure the URL says https, but nothing is working.

We were also having this issue last year, but did get it resolved. Unfortunately I cannot recall the exact steps we took to resolve. But if I recall correctly, it came down to using the proper YouTube URL. 

I looked at one of our embedded videos. We used the Widget Connector, and this is the URL pasted into the Web SItes URL field:

https://www.youtube.com/watch?v=eCnsfmPqzhA

This is a Smartsheet video Nothing was entered into the width or height fields. 

I'd suggest creating a page and trying this exact URL. The Preview area should show the video. Save it and see if it works. 

This will at least ensure you are using a proper URL, so if it does not work, you can eliminate that as a possible part of the problem.

0 vote

I get the same problem with vimeo though. If I use the external video link it will work (but only be a link), but if I use the internal widget connector (the standard way), nothing starts.

Could using a private link be the issue? I don't want the stuff shared all over so I used private link only but that shouldn't matter as far as I can tell.

Anyone know anything more?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,606 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you