Why wont my "Table of Contents" work when linking within the page?

Hey guys, sorry to bother but I'm a bit stumped on this issue I'm having with the table of contents. 

 

Basically I have a list of things on a doc page...I brought in a very basic default "table of contents" that links to certain headers within the page. 

The table was working great at first but now when I'm on the page and I click on a link in my table of contents, it still properly changes the link in the address bar, but it no longer jumps down to the portion of the page. If I take that link and open it on a new tab or browser, it jumps to the right section.

Is this a known bug or am I doing something wrong?

4 answers

Hey buddy, Does this happen on a different page? Have you tried different browsers? Have you tried deleting and redoing the headers and remove/add the table of contents macro? Darren

Hey Darren, 

Thanks for the quick response. I have tried removing the table,adding in new ones, cleared browser cache and I deleted a few of the headers to no avail.

I've checked on Chrome and Firefox and I had my coworkers try it on their computers...they are getting the same thing.

I thought the issue was on only on my particular page but I just looked at our existing pages from the beginning of the year and those seem to be having the same issue too?

If you want to take a look, the following link will take you to one of our pubnlic pages...just click ona table of contents and youll see that it wont jump down unless you open that link on a new tab or hit the refresh button after clicking on the table of contents link: https://finproducts.atlassian.net/wiki/display/FINStack/FIN+Watcher

 

 

 

 

 

 

Hey Darren, I will have an admin check that link you sent me tomorrow...What should we be looking for? 

Also, what are some conflicting addons? we haven't added any recently..definitely not within the time frame that these links stopped working. 

 

sorry if you dont see this. It wont let me comment or answer anymore since Im under 3 points? I can only do it once every 24 hours apparently.

No problem at all.. Cloud Confluence also, gimme a sec.. taking a peek now buddy

https://finproducts.atlassian.net/wiki/display/FINStack takes me to the page, the extra bit on you login forces me to want to log in :-) Checking now...

Hmmm.. I see what you mean.. Gimme a sec, I have a test cloud instance.. Will test..

Have you tried a re-index, the one that locks the instance? Looking at mine, same version is working fine.. So it's possible you have a conflicting addon, or have some code in the header here: https://finproducts.atlassian.net/wiki/admin/custompagecontent.action

darrenDOTpeggATodonus.co.uk ;-)

Hey Darren, What code should I be looking for in the header section? I just got access to someone with an admin account for our Jira docs. It still isn't working..and we haven't added any addons..especially not since the time when the table of contents linking already worked.

0 vote
Ben Kelley Atlassian Team Dec 02, 2015

When I have seen this before it was generally to do with how the browser handles intra-page anchors, where the anchor text contains certain characters.

e.g.

If you have a section heading called "Overview", it will generally work well in all browsers.

If you have a section heading called "Questions?" the "?" will make it into the anchor text. On Windows (for example) this won't work in Firefox, but it will work fine in IE.

0 vote
Danny Harris Community Champion May 12, 2018

Hi @Christopher Sim4,

Are you using Confluence Server?

Thanks

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

615 views 21 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you