Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why isn't my MP4 attachment playing?

I am trying to upload an MP4 video file to a Confluence page. When I am in the editor, the video will upload with a preview and the video will play. 

Screen Shot 2022-01-10 at 1.47.23 PM.png

However, it refuses to publish the page with the loaded preview. Instead, I have to refresh the page and publish it before the video preview loads. The published page shows a loading screen for the video preview.

Screen Shot 2022-01-10 at 1.50.42 PM.png

Clicking on the preview will not play the video, and the preview never loads. Other viewers are also unable to play the video and see the same preview screen. How can I fix this?

2 answers

1 vote
Brant Schroeder Community Leader Jan 10, 2022

@Laura Needham I have mostly seen this with the file name.  Make sure you do not have any spaces or special characters in the file name.  I would suggest renaming the file to something simple example: salesforceupdate.mp4 and trying again.  

Thanks for responding, @Brant Schroeder ! Unfortunately changing the file name did not solve the issue - any other suggestions?

Brant Schroeder Community Leader Jan 12, 2022

How large is the file?

It's listed as 1.52 GB, but I'm not sure why as it is a cropped version of a 200 MB file.

Brant Schroeder Community Leader Jan 12, 2022

The max files size by default is 100mb.  My guess is the file is not actually uploading.  Do you have a smaller video file you could test with?

Like Fabian Lim likes this

Thank you for the suggestion! I uploaded a smaller video file (8.4 MB) and it did work - is there a way I can increase the maximum file size?

0 votes
Fabian Lim Community Leader Jan 10, 2022

Hi @Laura Needham

Welcome to hte community!

Are you uploading the file or copying and pasting it to the page?  If it's the latter, try manually updating first. 

Also, there is another thread about file name issues  as well: https://community.atlassian.com/t5/Confluence-questions/MP4-files-are-not-playing-in-any-brower/qaq-p/1548599

I hope this helps.  

Regards

Thanks for answering, @Fabian Lim ! I was uploading the file manually. I renamed the file to a simple name, and the problem persists. Any other ideas? 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

39,209 views 28 126
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you