Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why don't emoji's show in Confluence server? Edited

Trying to add emoji's in the page title or body using the mac cntrl+command+space option to add it results in "??" when published.

It shows the emoji when previewing just not in published view.

3 answers

0 votes
Jiri Hronik Atlassian Team Nov 05, 2019

Hi @Scotty Simpson 

Confluence supports emojis, they are supposed to show just fine.

What Confluence version and what database do you use?

Thanks @Jiri Hronik

Just checked and we're on 6.15.6 (which I don't believe is the most recent)

No idea about database

0 votes

Hi Scotty,

We will need more information to answer you better.
1. Browser
2. The broken Emojis (Generally, UTF-8 encoded emojis shouldn't have issues, however it also depends on browser's UTF-8 charset support)
3. Database being used in the background. 
4. Is it an Emoticon or Emoji?

Meanwhile can you please look at the following post for more info:
Emoji's getting deleted after updating the page

Ah so I've discovered a few other things. Emojis are working on paragraph text but not in headings or page titles.

Like # people like this
  1. Google Chrome 78.0.3904.87
  2. I was trying https://emojipedia.org/clown-face/ which is UTF-9 but even https://emojipedia.org/white-left-pointing-backhand-index/ didn't work in title and headings
  3. Not sure, how do I check this?
  4. Its an emoji
GG Atlassian Team Nov 05, 2019

If you are an admin, you can check it in admin panel in system information under database tab.

2 color icons that is displayed in a browser is ok in page titles

https://emojipedia.org/people/

Image 231.png

I have a similar problem.  Emoji's work in the body of the page but not in the title.  I want them in the title so I can have fun page tree like this! https://www.atlassian.com/software/confluence

Hey, I have solved the problem. Consider using common emoji sets that supported by confluence fonts and rendering is supported by browsers. Just copy and paste emojis from the pages provided. Here are lists I have checked for compatibility with conflience 6 : https://emojipedia.org/objects/ and https://bitbucket.org/gdwiy/bitbucket-emoji-list/wiki/Home?_ga=2.29565435.598122700.1574757159-477300901.1550910050

Like # people like this

@Max Aster You are my hero right now!!!!! it worked! thank you thank you thank you!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

463 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you