Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Emoji's getting deleted after updating the page

Hello,

 

Confluence version: 6.14.0

While using emoji's in my Confluence page and saving the page for the first time I'm able to see the emoji, but after making another update to the same page the emoji disappeared and i will see words instead.

For example by writing (*) i will see the star emoji, and after updating the page i will see (star)

 

Please assist me to fix this issue.

 

Thanks,

Almog.

6 answers

1 accepted

0 votes
Answer accepted

Hi Almog,

Based on the behavior you described, it looks like this is a known bug, in which Confluence changes the emoji macro into a hard-coded image tag: CONFSERVER-52441 - Emoticon is changing to image after the first save and edit of the page.

However, while the storage format of the page changes, the emoji should still show, as long as it can be accessed at the URL (generated based on the base URL set in the admin settings).

Based on the storage format you provided, it looks like the base URL for your site is set to "http://192.168.3.8:8443". Is this the URL you use to access Confluence? If not, I recommend updating the base URL to use the same address entered in your browser, and it should be able to pull up these macros. (Note: this will take effect on any newly-created emoji; any existing broken ones will stay hardcoded to 192.168.3.8).

See also: Configuring the Server Base URL

I hope this helps!

Hi Zak,

 

The URL to access my Confluence is https://192.168.3.8:8443, and this is also my base URL which is configured in the General settings.

Unfortunately i guess it's not the issue here.

 

Thanks,

Almog.

Thanks Zak,

 

I'ts really frustrating that the bug ticket is opened since May 2017, and there is no progress since.

Hope they'll fix it soon.. :(

 

Thanks,

Almog.

Hi Almog,

I noticed something coming back and taking a second look. You mentioned your base URL is set to "https://192.168.3.8:8443", but Confluence automatically set the emoji URL to "http://192.168.3.8:8443/[...]" (http, not https). 

Based on this, it seems that your base URL may actually be set to "http://192.168.3.8:8443/" (not https). Can you confirm this? And if it is http, is the issue fixed when you change it to "https://192.168.3.8:8443"?

Fingers crossed this helps!

Hi Zak,

 

My base URL is the correct one (https://)

 

Thanks,

Almog.

Like Noumenon72 likes this
1 vote
Zak Laughton Atlassian Team Feb 12, 2019

Hi Almog,

Interesting that the emoji work on the first save, then break after the second.

Is the markup content on the page changing at all? I'd be curious to see, since this might narrow down a root cause.

Try the following:

  1. Create a page with the star and save it
  2. On the page, go to ellipsis > View Storage Format
  3. A window will pop up showing how the emoji is saved on the page at a markup level. Copy this text somewhere.
  4. Edit and save the page to break the emoji.
  5. On the page with the broken emoji, go to View Storage Format and see if the content has changed since step 3.

If the content did change, then something about subsequent changes is actually updating and breaking the emoji.

If the content did not change, then somehow the content is being interpreted differently after the first save, even though it is the same.

Also, does this happen in different browsers?

Hi Zak,

 

Thank you for your reply.

I tried the steps that you gave above, and i found that the text did changed.

At first it was: <p><ac:emoticon ac:name="yellow-star" /></p>

After re-editing it changed to: <p><img class="emoticon emoticon-yellow-star" title="(star)" src="http://192.168.3.8:8443/s/en_US/7901/9eed016aaa593220cd98620fec88bcbd9fd55893/_/images/icons/emoticons/star_yellow.svg" alt="(star)" border="0" /></p>

 

Also, tried using different browsers and it's still happening but a little bit different while using Internet explorer for example.

 

I received the same output from checking the Storage Format, but i see a " . " (Point) instead of broken emoji.

 

Hope you can assist me with that.

Thanks,

Almog.

Like Noumenon72 likes this

Dear all,

 

We experiment the same issue with Confluence 6.15.4.

How did you manage it?

 

Base URL has not been changed on our side.

 

Best regards,

Same Problem for me.

How to reproduce: 

a) create / edit / update a page. The URL of the emoticon ist like this: 

https://SOMESITE/confluence/s/en_GB/8100/b0984b7297905b7c7bd946458f753ce0130bfc8c/6.15.4/_/images/icons/emoticons/star_yellow.svg

 

b) Edit the page - no change on emoijs, URL changes to: 

http://SOMESITE/confluence/s/en_GB/8100/b0984b7297905b7c7bd946458f753ce0130bfc8c/6.15.4_/images/icons/emoticons/star_yellow.svg

 

The problem is the scheme change from https TO http! AND the 6.15.4_/ is changed to 6.15.4/_

Seems, that the rewriting in confluence is NOT working correctly (I suppose, that handling the regular expression escape characters is NOT done in the correct way....

Hi @Almog yehezkel,

Try disabling auto-formatting in your settings and see if this behaviour continues or not. This should mostly fix the issue. Refer to the Editor preferences section in this page for more information.

Thanks

Sireesha

Hi Sireesha,

 

Thanks for the assistance, but unfortunately this is still not working for me, while disabling the Auto-formatting i couldn't use any emoji at all, for example while writing (!) even in the edit section i couldn't see the emoji at all.

 

Maybe it's something else.

 

Thanks,

Almog.

Like Zak Laughton likes this

Hi,

since you're into icons, we have just released Icons for Confluence (cloud), a set of +500 fully customisable icons (colour, size, shape) to be added to Confluence documents. Hope you might give it a try! Thank you

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

539 views 3 23
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you