It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why can't I embed video on a page?

I've attatched a video as .mp4 and when I look for the macro to embed it, I can't. Is this a macro that needs to be enabled? If so, how? What even is the correct macro/process for embedding a video?

Thanks for your help.

3 answers

1 accepted

5 votes
Answer accepted
Marian Finch Atlassian Team May 12, 2013

Thanks for providing a screenshot. I tested this using all of the methods mentioned above and was able to successfully insert the Multimedia Macro. For security purposes only our OnDemand Support Engineers have access to your instance to further assist in troubleshooting this issue. You can submit a support request 24/7 via support.atlassian.com - make sure you select the OnDemand Support Project. One of our OnDemand Support Engineers will be able to resolve this issue for you and get the Multimedia Macro back up and working :)

Again please don't hesitate to shoot me an email at sales@atlassian.com if anything else comes up!

4 votes
Marian Finch Atlassian Team May 10, 2013

There are four different ways you can go about displaying multimedia content on a Confluence OnDemand page as mentioned in the Embedding Multimedia Content doc. All of which are supported for .mp4:

  • Add the macro yourself: Attach the multimedia file to the page in the usual way. Add the Multimedia macro using the macro browser.
  • Autocomplete: Attach the multimedia file to the page in the usual way. Type '!' in the editor and choose the multimedia file from the list that appears.
  • Drag and drop: Drop the video or other file into the editor. Confluence will attach the file and insert the Multimedia macro for you.
  • Adjust parameters if necessary: Click on the Multimedia macro placeholder to set options for the macro, such as adjusting the width or height of the display, or setting autoplay on.

It seems odd though that the Multimedia Macro isn't showing up for you. When you edit a page and go to > Insert > Other Macros> and type in 'multi' ideally the Multimedia Macro should appear. Do any results render when you type in 'multi'?

I should also mention that this functionality comes enabled by default through the bundled system plugins and cannot be disabled.

If you have any additional questions please don't hesitate to email sales@atlassian.com and ask for Marian :)

Marian Finch || Product Advocate


No multimedia macro... any idea why this is?

Like Ralph Medina likes this

Why can't I embed a video in confluence answers comment?

For me, it is showing Multimedia macro but does not allow to attach file.

The  Embedding Multimedia Content link posted (above) is now a broken link.

Also using the Multimedia Macro is not advised because it's broken in Confluence Cloud. Using this macro somehow disables inline page commenting. 

https://jira.atlassian.com/browse/CONFCLOUD-64738

I'm looking for alternatives to playing attached multimedia.
https://community.atlassian.com/t5/Confluence-questions/Inline-comment-writing-is-unavailable-on-child-pages-Why/qaq-p/936636#U936655

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Introducing Confluence Cloud and Jira Software Cloud Premium

Wherever you are in your team’s journey , our goal is to support your big ambitions. We’re a cloud-first company with the mission of unleashing the potential of every team, and to address the range ...

616 views 4 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you