Why Space Directory is blank?

The space directory under the browse menu is showing a blank page on our production system. However this is working on the development system.

On the development server I discovered that SubSpace plugin was creating the issue so I disabled the plugin and space directory started showing. But on production system when I disable the plugin (subspace), it is still showing a blank page.

6 answers

Hi there,

Please try the following steps

  1. Shutdown Confluence instance
  2. Remove the following directories (backup if necessary)
    • <confluence-home>/bundled-plugins
    • <confluence-home>/plugin-cache
    • <confluence-home>/plugins-osgi-cache
    • <confluence-home>/plugins-temp
    • <confluence-home>/bundled-plugins_language
  3. Restart Confluence
  4. Try to rebuild indices from scratch
  5. See if the problem persist

Hope it helps.

Cheers,
Septa Cahyadiputra

The above fixed this problem for me. I had just upgraded from 3.0.1 to 4.2.11.

I tried the above solution, but it did not work for me. I noticed the space directory was blank in 4.0, so I upgraded to 4.2.12. I followed all the steps above including rebuilding indices from scratch. The space directory is still empty.

We had the same behaviour, than I looked at the subSpace-Plugin and saw the module "Confluence 4 Standard Theme Integration" which was disabled by default.

After enabling the space-directory worked.

solved it by resetting the Layout/Global Layout to default. I had some customizing there.

Robert

Another possible cause in: Empty Space Directory Page after Upgrading Confluence: https://confluence.atlassian.com/display/CONFKB/Empty+Space+Directory+Page+after+Upgrading+Confluence.

We recently upgraded to Confluence 5 and I've found a space that is completely empty. Are your pages missing in these instances or just the directory structure? I'm wondering if this is the same issue.

Thanks,

I had the issue when we migrated the DB? Is this connected? Even the people directory is blank.

Resetting the Global Layout (Admin->Layouts->Global Layout->Reset to Default) fixed this for me as well. Thanks Robert.

 

Jeff

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,608 views 4 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you