User Can't Log in - Directory not functional during authentication

Hi, one of the users on our Crowd set up cannot log in to confluence

Jira is the user directory (pointing to an Active Directory server)

All application links appear ok

The error log is as below (markg cannot log in, alexc can log in)

I have reviewed and followed this article with no joy https://community.atlassian.com/t5/Confluence-questions/Confluence-JIRA-quot-Remote-user-directory-is-not-functional/qaq-p/349786

Thanks

Alex

ERROR [http-nio-8090-exec-9] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'markg'. Skipped.

ERROR [http-nio-8090-exec-12] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'alexc'. Skipped.

1 answer

1 accepted

0 votes
Answer accepted

Alex - can the user log in for JIRA? Does he have the permissions for Confluence, e.g. is he in a group which has Confluence user rights?

Cheers

Christoph

Hi Christoph,

Thanks for coming back to me

Yes to all of the above

Hi Alex, 

Can you search for the user in Confluence? Has he already been able to log in? Is the user new to JIRA (it might take some time to sync)? Is there anything else in the log? 

Cheers 

Christoph 

Hi again,

Yes again to all of the above. There is quite a bit in the log which the forum won't late me paste (i get an error on here

"Error

Your reply was not accepted. Please check for inappropriate language or spam.")

Thanks again

Alex

Hi Alex

so please post it somewhere on the web and link to it here ;)

Cheers

Christoph

Alex - I have just found this kb entry for crowd - it might be helpful for your issue too: https://confluence.atlassian.com/crowdkb/crowd-user-authentication-fails-with-directory-x-is-not-functional-during-authentication-error-391086721.html

I am wondering what is the difference between both users? Have you tried to remove the non working using from the Confluence users group and add him again? Have you tried to reestablish the connection between JIRA and Confluence? 

Cheers 

Christoph 

Hi Christoph!

We are working! 

I noticed that the ip addresses in the Jira User Server setting were out of date!

Thanks so much for your help 

Alex

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,242 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you