Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,075
Community Members
 
Community Events
176
Community Groups

User Can't Log in - Directory not functional during authentication

Hi, one of the users on our Crowd set up cannot log in to confluence

Jira is the user directory (pointing to an Active Directory server)

All application links appear ok

The error log is as below (markg cannot log in, alexc can log in)

I have reviewed and followed this article with no joy https://community.atlassian.com/t5/Confluence-questions/Confluence-JIRA-quot-Remote-user-directory-is-not-functional/qaq-p/349786

Thanks

Alex

ERROR [http-nio-8090-exec-9] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'markg'. Skipped.

ERROR [http-nio-8090-exec-12] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'alexc'. Skipped.

1 answer

1 accepted

0 votes
Answer accepted

Alex - can the user log in for JIRA? Does he have the permissions for Confluence, e.g. is he in a group which has Confluence user rights?

Cheers

Christoph

Hi Christoph,

Thanks for coming back to me

Yes to all of the above

Hi Alex, 

Can you search for the user in Confluence? Has he already been able to log in? Is the user new to JIRA (it might take some time to sync)? Is there anything else in the log? 

Cheers 

Christoph 

Hi again,

Yes again to all of the above. There is quite a bit in the log which the forum won't late me paste (i get an error on here

"Error

Your reply was not accepted. Please check for inappropriate language or spam.")

Thanks again

Alex

Hi Alex

so please post it somewhere on the web and link to it here ;)

Cheers

Christoph

Alex - I have just found this kb entry for crowd - it might be helpful for your issue too: https://confluence.atlassian.com/crowdkb/crowd-user-authentication-fails-with-directory-x-is-not-functional-during-authentication-error-391086721.html

I am wondering what is the difference between both users? Have you tried to remove the non working using from the Confluence users group and add him again? Have you tried to reestablish the connection between JIRA and Confluence? 

Cheers 

Christoph 

Hi Christoph!

We are working! 

I noticed that the ip addresses in the Jira User Server setting were out of date!

Thanks so much for your help 

Alex

Like Martin Herren likes this

Hi Alex, 

 

We are also facing the similar issue 'Directory' is not functional during authentication of 'jirasupport' skipped.

 

Can you please help us on how to fix this issue.

 

Best Regards,

Dinesh Loyapalli

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events