Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to create comment. Create your highlight on more unique text....

I've tried every which way (sentence, words, word, punctuation, header, etc.) with adding an inline comment, but continuously get the following error: 

"Unable to create comment. Create your highlight on more unique test, to make the selection distinct, so that your comment maps to the right content."

 

Any help would be appreciated. 

5 answers

1 vote
Shannon Atlassian Team Mar 03, 2021

Hello Community!

For anyone encountering this issue, the bug for tracking is:

I suspect the length of the selected text may be the issue. Can any of you save the inline comment with a smaller portion of text? What seems to be the limit?

Thank you for your help,

Shannon

I am having the same problem. I've tried the work around and it still doesn't work. This is really important for our team project coming up.... someone please advise!

Capture.PNG

Hello,

first of all, there is this bug: https://jira.atlassian.com/browse/CONFCLOUD-70504

Then, what happens sometimes is when you have copied and pasted text from that same page and then want to highlight that pasted text and leave a comment, then this won't work.

Try deleting the pasted text and manually enter it again, publish the page and try to comment then. This worked for me sometimes.

0 votes
Diego Atlassian Team Aug 31, 2020

Hello there! Thanks for sharing here with the community, @Tonya Seibert !

I tried to replicate the behavior in my Confluence site but was ultimately unable to. I can create in-line comments in both unique and non-unique strings of texts inside my pages:

Screen Shot 2020-08-31 at 16.41.47.pngScreen Shot 2020-08-31 at 16.41.58.pngScreen Shot 2020-08-31 at 16.42.08.png

However, I was able to find a bug report that tries to tackle this exact behavior:

Currently, there is no workaround for the behavior. With the fact that I was unable to replicate it, I would like to ask you a few questions. Here we go:

  1. Is this still affecting your site?
  2. Are you unable to place in-line comments in all your pages or only specific ones?
  3. Is this happening in both Legacy and New editor?
  4. Is this happening with already existing pages?
  5. Is this happening with newly created pages?

You can differentiate between the Legacy Editor and the New Editor by looking at the top bar:

 

Legacy Editor:

Screen Shot 2020-08-31 at 16.49.49.png

New Editor:

Screen Shot 2020-08-31 at 16.48.50.png

Let us hear from you!

Same here, started happening today

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,683 views 7 31
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you