Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,545
Community Members
 
Community Events
176
Community Groups

Trello Board not displaying in Confluence

Edited

I have tried to add an existing Trello Board in to my Confluence page using the + Trello macro but the board does not display. Instead, I get a:

Board not found.

This board may be private. You may be able to view it by logging in.

When I try clicking on the link, a pop-up window appears but then disappears immediately with no ability to log in.

Setting the board to Public does allow it to display in Confluence but this isn't safe as I don't want Private company information to be searchable on Google etc.

Any suggestions on how to fix this?

6 answers

3 votes
Peter DeWitt Community Leader Feb 21, 2022

Safari Users Rejoice!

You need to disable (uncheck) Prevent Cross-Site Tracking.

Safari->Preferences->Privacy->Website tracking: (uncheck)

For me switching browsers solved it. Couldn't get it to work with Safari, even after following all instructions and disabling content blockers and even pop-ups for atlassian.net and trello.com. But works in Chrome!

Same issue. Used to work fine until the stupid account merging - now is stuffed.

 

Solution: 

If you haven't logged in into trello when using it on a confluence page, the error message that you have mentioned appears. It is correct, when you attempt to tap on it to log in/sign up nothing happens. 

 

What you have to do is the following: After posting the Trello macro onto your confluence page, you then click on the edit button which will take you back to the preview screen - there you will be able to tap on log in/sign up taking you to an external URL. 

 

Log in/sign up. Go back to your confluence page, delete the macro that you have created. Create another macro using the same Trello board URL and this time around it should work. 

 

If you are having problems in accessing the log in button on preview with the Trello Board Macro, give it a try with the Trello Cards Macro. 

Are you serious?

Do you have to hold your mouth a particular way or does it only work on Full Moons?

If this is what you have to do to get a Trello board to display in Confluence then it can go in the bin.

Like # people like this

Hi - having the exact same issue... did you ever manage to resolve this!?

0 votes
Diego Atlassian Team Jan 04, 2019

Hi there Gareth!
It seems that you may need to authorize access for Trello, as described here:

Trello - Using the Confluence Power-Up

You can also take a look into our article for Confluence Cloud and Trello:

Use Trello and Confluence together

Basically, Confluence needs permission to use your Trello account for:

- create cards
- edit cards
- see your boards

Also, each user needs to authenticate their Confluence accounts within Trello for this integration to work as expected.
Let us know if this documentation helps you out!

Hi Diego

Thanks for getting back to me. I tried following the notes in the pages you linked to but sadly no further forward. I have set the board visibility to just me (private) and the board is not shared with any other user. I can confirm that the Confluence power-up was added to the Trello board and that Trello received the authentication from Confluence.

And I can confirm that this is the same account for both Trello and Confluence.

However, when I go back to the Confluence page, I still get the message ‘Board not found. This board may be private…’

In addition, I can confirm that it works in the other direction, i.e. when I click on the Confluence Powerup in Trello and add a link to my Confluence page it is correctly rendered within the Trello Card.

Any further ideas?

Don't know how relevant it is, but I had the same problem and a tracker analytic addon was causing it (ghostery). Worked when I trusted both sites (bitbucket and trello).

Like Aki Nishanov likes this

Does not work for me either (Safari) :-(

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events