Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The zip file did not contain an entry 'exportDescriptor.properties' Edited

My task is to migrate the data from a Confluence cloud instance to an empty Confluence server instance.

I'm creating a backup from the cloud instance as described here: https://confluence.atlassian.com/confcloud/create-a-site-backup-724765526.html

I download this file to my windows 10 laptop.

I've created a Ubuntu 18.04 server with docker and have the image cptactionhank/atlassian-confluence:6.12.2 up-and-running.

The cloud-export is first copied from my laptop to the Ubuntu server and than copied from the Ubuntu server into the docker container in /var/atlassian/confluence/restore

Then I open https://aaa.bbb.ccc.ddd:8090 in my browser (chrome) and follow the steps to setup confluence (using a postgres 9.6 database).

I select the option to restore data.

I see the cloud-export in the list under "Restore a backup from the Confluence Home Directory", select it and press on "Restore".

After a few seconds The page is refreshed and I get the following error:

The following error(s) occurred:Annotation 2019-09-02 121202.png

As you can see although the error states the file exportDescriptor.properties is missing, it actually does exist in the file.

Unzipping on my win laptop or in Ubuntu also shows the file is existing!

What I noticed (might be unrelated) is that the modified timestamp of the files in the zip are in the future (2090-02-28 09:10).

I tried modifying owner and R/W attributes, etc. but nothing worked...

I also tried to unzip the file and zip it again (only exportDescriptor without other files and some other variants), but this didn't help either.

To rule out the fact that the file might be somehow corrupt, I re-created a new cloud-export. It had the exact same results :-(

In a previous testrun of this migration I didn't see this error, but I can't figure out what I did possibly do different or what might cause this issue this time...

I searched already this community and atlassian docs, but wasn't able to solve it yet.

  • I have sufficient diskspace (both on the filesystem where the export is stored on the host as in the docker environment)
  • The file does contain the file reported as missing
  • (Initially) the file was not modified between cloud export and server restore process (except downloaded from cloud instance and copied to Ubuntu server where Confluence server is running (in docker).

After 2 days troubleshooting I'm out of options. I'm hoping someone give some clues to solve this issue...

2 answers

Hi Diego,

I found that document (and others) about this issue, but the resolutions didn't work (that's why I created a new question).

Finally I found the cause yesterday morning and was able to resolve the issue.

Unfortunately by that time my question was marked as spam without any notice or explanation and I was not able to provide my solution (that doesn't motivate to participate in the community...)

Anyway, thanks for your answer and I'll provide the cause and solution below.

 

In the logfiles I found information that the unzip process failed because of accessrights. I've mounted <confluence-home>/temp (where the restore process tries to unzip the file) as readonly. In a next log entry I noticed the error that it could not find the file exportDescriptor.properties in the temp folder (which is logical because the previous unzip operation failed...)

So the error in the web frontend about the missing file was misleading  and even incorrect! (cost me more than a day)

After mounting the temp folder as read-write everything work smoothly

 

I would suggest to improve the errorhandling and report to the web frontend already that the unzip operation failed.

Diego Atlassian Team Sep 05, 2019


Hey @Roger Niesten , thanks for sharing your experience with us. Reports like yours help to improve our community.
Sadly, your experience was not top-notch, as we would have expected. Other than the strange spam flagging of your question, do you have something to point out in the Community flow that we could look into?

But alas, let us move forward! I really appreciate that you took your time to come back and update the thread with the final solution. Your report can and will probably help other customers that face similar issues.

Roger, thank you for taking part in our ever-growing community!
Let us hear from you.

0 votes
Diego Atlassian Team Sep 04, 2019

Hello, @Roger Niesten !
Looking through our documents, I can see that we have this situation listed. Here you can find more information about it:

In the article above, many reasons for this issue occurrence are discussed and explained, Roger.

Also, are you able to check if the procedure you followed is this one:

There are a few specifics that should be dealt with when migrating. This document takes care of it.

Let us know if this helps you out, Roger!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

383 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you