The Undo button is no longer available on my toolbar after the latest UI changes, where did it go?

Deleted user October 24, 2017

The Undo/Redo button used to be available on the far right right of the tool bar when I was editing a page. Both those buttons are now missing? Is there a setting to change the toolbar contents that I am missing?

35 answers

17 votes
Admin2 December 4, 2017

It is ridiculous that anyone ever thought that this was a good idea, put them back PDQ. Yet another reason to dump Atlassian products as they keep assuming that everyone knows all of the keyboard shortcuts. Far simpler to use a button anyway!

Rick December 6, 2017

"It is ridiculous that anyone ever thought that this was a good idea"

 

I totally agree!

Like # people like this
olisteadman May 2, 2018

+1 omg this is a fundamental tool within plenty of JIRA's competitor apps ... cmd+Z does not seem to work here when wanting to Undo the dragging of cards from one list to another... am I missing something?

Like # people like this
Anton Zhukov June 29, 2019

After I removed a column in a table in the article, I can not 'Undo' this action with cmd+Z...

Seems like the Undo functionality is not working properly, that's why they just decided to hide this functionality :D 

Like # people like this
Andrei Bolbat September 4, 2019

Yep, came here to see if I can undo a removed table row.

Roch Brz June 6, 2021

Yup. Same issue.

Actually, undo doesn't work at all...

10 votes
Jay Dalke February 9, 2018

Unbelievable that after several months this the undo button still hasn't been brought back.   There is an old adage "If it isn't broken don't fix it".  This was a commonly used feature that exist on just about every single editor everywhere - to remove one small button to "supposedly" clean up the UI - is absurd and a poor product choice!

7 votes
Marko Lehtimäki December 18, 2017

Bring them back, please!

These standard shortcuts aren't that widely know outside the developer community. I'm trying to promote Confluence as a documentation tool in our organization. Now it is somewhat harder when the editor is suddenly missing two frequently used buttons.

7 votes
Jules Rasar October 31, 2017

I am curious about usage.  Did you use analytics to help make this product decision?  

That button is one of our mostly widely clicked buttons.

olisteadman May 2, 2018

Agree - I needed to Undo within 1 minute of starting my first JIRA Kanban and the lack of this feature has cut my explorations short! ... cmd+Z does not seem to work here when wanting to Undo the dragging of cards from one list to another... am I missing something?

5 votes
Vanessa Wilderink March 13, 2018

Please bring them back!!  Those buttons are NOT space wasters but control key commands are definitely time wasters if you don't use them all the time.  

4 votes
Melissa Gerrier-Satagaj March 27, 2018

Shortcuts do not appear to be working.  I know this because I deleted my last two hours worth of work in error and cannot get it back.  

Unfortunately, I cannot just copy and paste a table from Excel to Confluence as the formatting is lost.  

Confluence Team - this is not acceptable.  If I am trying to use your tool to manage my project and documentation, how can do so efficiently when even the most simple restoration task cannot be accomplished??????

3 votes
JPerton June 4, 2018

Send Atlassian a bill for all the time you wasted because some dimwit decided that this was a good idea and get the word out on social media. Everyone's pleading and begging are falling on deaf ears. What is the CEO's email address? Start sending the CEO an email. Look how effective that is for Amazon.

If all else fails - cancel. That will get someone's attention.

2 votes
philoye
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 19, 2018

Thanks everyone for your feedback on this issue, and I'm sorry this change has been so disruptive to you. We have a public ticket tracking this issue, which I encourage you to follow: CONFCLOUD-58034.

2 votes
Alan Pauza March 19, 2018

Agree 100% with other commentators here.  Even the 'help' pages for Confluence still show images with the undo/redo buttons, and I had to use google to find the answer - I thought I'd somehow changed my settings to not show these buttons.

Removing these buttons hardly helps with uncluttering - but does adversely affect the useability.  I'm pretty disappointed that these have been removed -  the editor used to be very very simple to use for 'newbies' and so adoption was easy. 

Expecting users to know keyboard shortcuts is extremely unrealistic. Even more disappointing is that these keyboard shortcuts are NOT listed in the 'keyboard shortcuts' help popup. 

What action is Atlassian going to take and when? 

@Phil Oye are you still out there?

2 votes
Parker Crawford November 8, 2017

I use the undo and redo ALL the time.   Please bring it back!

Laura Heller June 7, 2019

Bring back the Undo / Redo.

Grace McIntyre June 18, 2019

I can't believe this is still not back in the UI! How do we get them to bring back this basic functionality?

1 vote
Gemma Lajbrok June 26, 2018

Does anyone else get the feeling Atlassian are just sitting back and watching the drama unfold in the thread with amusement? I can't see why there'd be so little feedback or action otherwise. I suspect our outrage is quite hilarious for them. 

1 vote
Melissa Gerrier-Satagaj June 19, 2018

Migrating my documentation from Confluence to Box today.  We'll then use SharePoint to collaborate.  

I cannot expect my partners to use an application that doesn't allow for even the most simple of functions - specifically, the undo function. 

It is unreasonable for Confluence to make a conscious decision to make even the most used tasks laborious and frustrating.  

Ease of use for my partners and customers is priority 1. 

Too bad that Confluence doesn't feel the same way.

1 vote
Helen Silby April 8, 2018

Please add the undo back - those shortcuts don't even seem to work! (well they didn't for me....)

Gayatri Puwar Mahendroo June 10, 2019

same here. surprised such basic things not being available for the editor.

1 vote
philoye
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 24, 2017

Hello,

I'm a product manager on Confluence Cloud. Thanks for your feedback.

We have removed the toolbar buttons for Undo/Redo as a starting point to streamline the editor, as well as to align other tools.

Undo/Redo are both accessible via standard keyboard shortcuts: Command + Z / Command + Shift + Z on the Mac and Control + Z / Control + Y on a PC.

However, we are monitoring feedback on this, so thanks for raising it.

Deleted user October 27, 2017

meh. One person's streamlining is another person's missing tool. Why not just make the toolbar configurable so users can clutter or unclutter as they like.

Like # people like this
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 27, 2017

Much as I'm an Atlassian fan-boy, I'm with Jill on this one.  By all means, streamline the defaults, but give the user a full range of options and let each user choose the ones they want.  Keyboard shortcuts are fine for many, but let people have their buttons too.

I've done a lot of work with people who struggle to read for varying reasons, so if I had this facility, I'd have dropped all the colour and italics buttons, to remind myself they're a bad idea.

Like # people like this
Andrew Williams October 30, 2017

Bring back the button. Nothing intuitive about keyboard commands using CTRL.

Like # people like this
Jana Volencova October 30, 2017

I miss this button so much. Using the shortcut is not an option for me since I use two different keyboards and Z alternates, so I never know (fast enough) where my Z is this time. 

Please put this button back. 

Like Laura Heller likes this
Jarrod Pearce October 30, 2017

I agree!! Bring back the button!!! The fact you don't give the user the option is ridiculous. 

Meghan Cassidy October 30, 2017

Completely understand wanting to streamline, but because the "undo" button in the toolbar of Chrome (macOS) does not work to actually undo anything within the Confluence editor (thus, we are forced to use the keyboard shortcut), taking away the buttons is actually an accessibility issue. It is very hard for some people to push two buttons at once, and while there are ways to get around that (the sticky keys setting for example), it would be much easier to just be able to press a button. Please consider putting the undo and redo buttons back. 

Like Andrea Benton likes this
Sandy Johnson November 3, 2017

I'd just like to add my vote for the return of the buttons

Sarah_Adams November 9, 2017

OMG, yes, please bring back those buttons!!!!

I just deleted a block of text by mistake, wanted to get it back, did not know about the shortcuts, and... lost it. Very sad. 

Like Gayatri Puwar Mahendroo likes this
Tim Ruijters November 24, 2017

When can we expect that those buttons are back?

Francesca Fabbri December 12, 2017

I really want them back!!

Like Gayatri Puwar Mahendroo likes this
Natalie Gould December 12, 2017

I am sorry to see these go as well.  I do use shortcuts, but have a much better visual and spacial memory, I have trouble keeping a huge number of shortcuts active and present in my mind, so tend to just focus on remembering those that I need to used repeatedly each day.

This falls under a very important action I need to use in Confluence, but not necessarily one I do repeatedly each day.  So instead of being "short" it will end up being long cut for me.

I also think this is pretty limiting for your user base, particularly for Confluence which seems like it should be accessible to a range of users from varying levels of technical skill.    

Sergey Sundukovskiy December 25, 2017

This is absolutely and utterly terrible

Lori Mendoza January 12, 2018

Agree with the above folks.  Bring back the undo/redo button.  I wasted 10 minutes trying to figure out why it was no longer present.  Like the idea of making them configurable -- meaning the user gets to select which buttons show up.   

Jordan M. Pflum January 31, 2018

Atlassian, please, Please, PLEASE put the undo / redo buttons back!  I cannot over-emphasize how bad of a decision it was to remove those.  Many users of Confluence are just normal business persons who do not know keyboard shortcuts.  This has already become a problem for adoption with use in my firm.

Shawn in Van February 1, 2018

Undo would be nice to bring back. 

 

Meghan Cassidy February 2, 2018

@philoye I know you said that you all are monitoring feedback on this, but we haven't heard a word back yet since you posted in October. Is Atlassian going to bring these back or not? 

Gemma Lajbrok February 19, 2018

Definitely bring them back. This is a regression, not a positive step,

Tracy_Grygiel March 16, 2018

This will actually be a deal breaker when I try to sell this to my company.  It seems like such an easy win to bring it back.  Please update us on the status.

David Herrington March 21, 2018

Agreed.  This was a bad UX decision impacting those of us who use the product every day.  Aesthetics are good during sales demos, but they are of little benefit to the people who have to use the products every day to do their jobs.  The UX design should at least allow users to turn off the "pretty mode" and go back into "work mode".

KSmathers April 6, 2018

just deleted a bunch of information unintentionally - couldn't find 'undo' and lost an hours worth of work - Confluence is difficult to use, not intuitive, and now even harder to figure out on the fly -

Like Gayatri Puwar Mahendroo likes this
Mike Reid April 11, 2018

Same here. Just made an error in a table and I now have to revert all my changes. Silly really how this product could not have a usable undo option on the screen.

Tom Mason May 8, 2018

the windows shortcut do not work properly, nor do the right click and select undo

Like Gayatri Puwar Mahendroo likes this
Michael Ross June 5, 2018

Do you realize you've broken the WAI/W3C accessibility rules? If you have limited dexterity, these key combinations can be difficult or impossible.

Further, using the keyboard shortcuts is ambiguous. You don't know for sure when you've undone or redone everything, whereas a button can be dimmed or disabled when there's nothing more to undo or redo. It's obvious that you're subtracting fundamental functionality from the UI, and this is undesirable - almost negligent.

Like Andrea Benton likes this
Tristam Stone May 21, 2020

And for iPad Pro users?? I cannot tell you how much work I have lost because of this. The new editor glitched out, selected a day's worth of worth and boom, gone. Could I undo, no. Was there a backup? No, Confluence was glitching out about auto saving. Cheers guys, streamlined.

1 vote
Gregor Kasmann_Actonic
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
October 24, 2017

Confirmed. Very strange behaviour.

Buttons shows for a few moments and then hides:

undo-redo-buttons.gif

philoye
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 24, 2017

That's definitely not intentional, thanks for pointing it out.

0 votes
Gregory Bradley March 13, 2024

I would be interested to know what Confluence User Group agreed that the removal of undo, redo buttons, was a good idea for this decluttering of the tool bar initiative.
I can think of other buttons that could have been removed before undo, redo. Probably undo, redo are the most frequently used buttons, given the quirks of the Confluence editor that occur. A totally stupid and poorly thought out update. 

BTW, I tried again today and the shortcuts Control + Z / Control + Y did in fact work, yesterday they didn't. 


Gregory Bradley March 14, 2024

Seems in my case this might be an operator error, that is me. Unfortunately I have to admit my mistake and ignorance here, I am new with Confluence cloud so forgive me. Just scraping the egg off my face, give me a moment;-) . 

I found the page was using the "legacy editor", so I did a new editor preview and then it looked OK, so I converted the page to the new editor. Then I chose the Update Option at top right, there is no publish on my confluence cloud at this point of the process.

After the editor conversion, when I go into edit mode on the page, the undo and redo buttons are there. So I don't know if there has been a change made by Atlassian after these complaints, or if this legacy edit page format is the issue for some. 

So for others, if you are not seeing the undo redo buttons, maybe you are still in the legacy editor? Check it out, it shows up top near the toolbar if you're using the legacy editor. 

Like Nic Brough -Adaptavist- likes this
0 votes
Bruce Hudson June 16, 2020

It's the middle of 2020 and still no sign of the undo/redo buttons. The menu bar has emojis, obviously critical for millennial morons that can't tell the difference between technical documentation and updates to their Instagram account, but no undo/redo buttons. No wonder our Confluence is littered with dead pages, broken layouts and links to O365 documents. 

0 votes
pauline April 19, 2020

The shortcuts for "undo" don't work.  Please post the new shortcuts so we can recover our work.

0 votes
Christopher Harris April 1, 2020

Control Command Z on my mac in confluence doesn't work.  I undid some typing and now can't get it back.  This is completely stupid these buttons are gone.  Developers don't assume everyone is a linux CLI over-nerd who has all the keystrokes memorized and force your culture on your user base.

 

I started programming at five years old, and have been in IT for 20 years and I didn't have the 'redo' keystrokes memorized.  I had to look them up, find this thread, and then discover the keystroke doesn't even work so it seems re-do does not work in Confluence.  A button would give more confidence that I can actually send the command to Confluence to redo.

0 votes
Manuel March 10, 2020

Whoever was the decision maker for removing this should be demoted. Hiding and icon and expecting someone to KNOW the keyboard shortcut for it is absurd!!!! This is a web-based program, not a local one, and most users will look for icons or menus for commands for things they can or can't do. 

I just lost an ENTIRE DAYS WORK because of this, and more importantly this was done because of the stupid formatting that is done. How could a program DELETE EVERYTHING PRIOR WITH ONE HIT OF THE DELETE KEY when NOTHING WAS HIGHLIGHTED!!!!!

Horrible design... go back and learn from other applications before.... NOT HAPPY RIGHT NOW!!!!

0 votes
Deleted user June 5, 2019

Please bring it back! 

Or perhaps remove some of the other useful buttons too, just to show exactly how little you listen to your users!!

0 votes
Tim O_Connor March 18, 2019

A breathtakingly silly design choice. Please put them back. 

Michael Ross March 19, 2019

Stupidity born of arrogance.

But what I don't get is that they've already agreed to put them back - they just won't commit to when. (As if this could take a developer more than a few hours work - the code exists, the icons exist.) Just put them the hell back! Or are they too proud?

Like Chitra Patil likes this
0 votes
Andrea Benton February 10, 2019

When are we getting this back?  Every time I make a blunder I have to go hunting to find how to get the changed / deleted content on the page back.  Whoever thought this was a good idea mustn't have consulted with many users.  And it's been over a year now.

0 votes
Corey Hawk January 22, 2019

I'm growing increasingly frustrated with products trying to overdesign crap that already works. No undo for an editing app is ridiculous. 

Quit solving for things that work and bring common sense back into the design workflow.

 

Now, where's my button to UNDO!?

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events