Table of contents is changing color

Hi, my table of contents macro sometimes shows black and sometimes blue -- and on one page it's doing a weird combination of both. Does anyone know how I can fix this? I don't see a color option on the macro editor.

This is confusing, as on some pages the table of contents does not look hyperlinked to users because of the changing color.

2 answers

1 accepted

Hallo Natalie

This sometimes happens because the headings themselves (the ones that the toc is based on) have some hard-coded colour codes applied to them. The headings can acquire colour codes if you paste them from another document, for example.

To fix the problem, try clearing the formatting on the headings: edit the page, select the heading, then choose the "More" formatting option in the editor toolbar (the big A with a little a next to it) and choose "Clear Formatting" from the dropdown menu.

I hope this works!

Cheers

Sarah

Great, thanks so much!

That helped. Thanks.

Britta T. I'm New Here Oct 15, 2018

Thank you so much! It did the "trick"!

That helped. Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

276 views 2 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you