Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Synchrony.port ovverriden, but synchrony do not start

Hello,

we run Confluence on Port 8091 on a Windows Server.

To use Synchrony on different port i have added 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\Confluence051118142118\Parameters\Java

  -Dsynchrony.port=8092 to the Options. After reboot i can see in systeminformation, that synchrony.port use 8092, but  synchrony still do not start.

ON Collaborative editing site under configuration is still the old 8091 port. Synchrony do not start.

Is there somebody who could help me?

Best Regards

Eduard

 

 

1 answer

1 accepted

1 vote
Answer accepted

I found the solution. Just for somebody who has the same problem.

After Change to different port reboot or restart of confluence service did not changed really everything. After change the collaborating Modus off and then again on it works.

please, can you tell what exactly you wrote, what is the line and in which file you wrote?

thank you. 

@Christian Ruf you are a life saver! I was having this same problem and couldn't figure out why Confluence kept showing the old port of 8091. Turning Collaborative mode off and on again fixed the issue--restarting Confluence service alone didn't do it.

Here's the full steps I took:

  1. Turn OFF Collaborative Editing on BOTH instances
  2. Stop both instances of Confluence
  3. Edit one of the instance's Java parameters to use port 8092
  4. Ensure sychrony.pid file is deleted for BOTH instances (https://confluence.atlassian.com/confkb/unable-to-restart-synchrony-after-confluence-was-not-shut-down-gracefully-957128787.html)
  5. Start the instance that you changed in step 3, and turn ON Collaborative Editing
  6. You should see the port update to 8092 now
  7. Start the second instance with the default port of 8091 and turn ON Collaborative Editing

Hello @eferrell

 

May I ask what do you mean on BOTH instances? I tried this steps but seems that it don't have effect on our synchrony port. This is the steps that I did:

1. Turn off collaborative mode.

2. End task confluence in data center

3. Edit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\Confluence051118142118\Parameters\Java

image.pngad

4. Start confluence services

5. Turn on collaborative mode.

 

But still it is on 8091 port. Thank you in advance for your help.

 

Best regards,

Neil Morada

@Neil Anthony Morada 

In my case, I had two installations of Confluence on the same server, and both were set to the default port for Synchrony which was causing collaboration mode to not work. I had to set them to two different ports.

I changed my java options through command line--not registry. I'm not sure if that makes any difference but its worth a try: https://confluence.atlassian.com/doc/configuring-system-properties-168002854.html

I would turn Collaboration on and off a couple times and restart the server to see if it changes.

Hi @eferrell 

 

Thank you for this, I will just try to turn of collaboration and restart the server until it change the port. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Wouldn't it be nice to have this Jira-Confluence integration?

...ossibility became true in a not too far future, project/space access would be left in the hands of all team members. Don't get me wrong: I'd love it! However, it would also be nice to have a way in which j...

77 views 1 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you