It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Synchrony is not starting up Edited

Hello

As I finally moved to my own nginx reverse-proxy, I thought I should be able to run Synchrony.

Unfortunaltely, synchrony is not starting. I have the same message as this person here: https://community.atlassian.com/t5/Confluence-questions/confluence-synchrony-editing-can-t-start-when-i-update/qaq-p/1202946 who in the end was advised to also open a ticket.

My setup is as follows:

- Confluence is running as a docker container in an ubuntu server (VM)

- The data for confluence is on an NFS share

- As database, a Postgresql Docker container is used

- Nginx reverse proxy is used to redirect to confluence

The confluence instance is directly reachable from the web with a subdomain (without the /confluence subpath), which redirects internally to http with port 8090.

I tried already what was mentioned in the thread above (removing the plugin caches). That did not help.

Thanks for your help
Roman

1 answer

0 votes
Bryan Bojorque Community Leader Jan 13, 2020

Hi @roman_baeriswyl ,

May I know what version is your Confluence to start with?

Synchrony port is 8091 please make sure that your forward the synchrony request in nginx.

localhost:8091/synchrony

I use the latest (7.1.0), I have updated it several times as it is running for quite a while now (I think it started with one of the first 6.x version).

Here is my current nginx script:

 

server {
    listen 443 ssl;
    server_name wiki.xxx.net;

    include conf.d/ssl.conf;

    location / {
      proxy_pass http://<ip>:8090;
      client_max_body_size 100m;
      proxy_set_header X-Forwarded-Host $host;
      proxy_set_header X-Forwarded-Server $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    }

    location /synchrony {
      proxy_pass http://<ip>:8091/synchrony;
      proxy_set_header X-Forwarded-Host $host;
      proxy_set_header X-Forwarded-Server $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
      proxy_http_version 1.1;
      proxy_set_header Upgrade $http_upgrade;
      proxy_set_header Connection "Upgrade";
    }
}

 

The main problem is that synchrony is not even starting as it throws the same exception as in the thread I linked above.

Hi @roman_baeriswyl ,

It looks good, maybe this is environment issue please attach your atlassian-confluence.log, also please sanitize it so sensitive data will not be included.

 

I remember 6.13.x has the stable version of Synchrony, for the latter there are stuff to do to make it work.

The logs can be found here: <hidden> 

Bryan Bojorque Community Leader Jan 13, 2020

Hi @roman_baeriswyl ,

It looks like it is related to Java.

Check your java version if it is updated, preferably Java 8.

https://github.com/oshi/oshi/issues/370

Well I'm using the official confluence server docker image (https://hub.docker.com/r/atlassian/confluence-server/)

I just updated from 7.2.0 to 7.2.1 which was released yesterday. Still the same, I cannot enable Synchrony, it just stays "off"

Startup log says:

Java Home: /opt/java/openjdk

JVM Version: 11.0.5+10

JVM Vendor: AdoptOpenJDK 

Bryan Bojorque Community Leader Jan 13, 2020

Hi @roman_baeriswyl ,

If your License does not expire yet your can create a support ticket to Atlassian.

Link your question here and they should be able to know what is going on in the instance.

Docker related issues are supported aswell.

It is a starter licence (still valid as I renewed it several times) but Atlassian does only support starters via this community channel here.

Any more ideas what could be the cause?

Bryan Bojorque Community Leader Jan 14, 2020

Hi @roman_baeriswyl ,

I tried to spin up a docker container with an image.

 image: atlassian/confluence-server:7.2.1-jdk11

It seems to be working fine on my end.

2020-01-14 12:59:34,313 INFO [synchrony-interop-executor:thread-2] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] debugPrintEnvironment /opt/java/openjdk/bin/java -classpath /opt/atlassian/confluence/temp/3.1.0-master-0f086db5.jar:/opt/atlassian/confluence/confluence/WEB-INF/lib/h2-1.4.196.jar -Xss2048k -Xmx1g synchrony.core sql
2020-01-14 12:59:34,373 INFO [synchrony-interop-executor:thread-1] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] isSynchronyProxyEnabled proxy port present: false
2020-01-14 12:59:34,373 INFO [synchrony-interop-executor:thread-1] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] isSynchronyProxyEnabled app config synchrony.proxy.enabled: true
2020-01-14 12:59:34,382 INFO [synchrony-interop-executor:thread-1] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] updateSynchronyConfiguration Synchrony External Base URL: http://0.0.0.0:8090/synchrony-proxy,http://0.0.0.0:8090/synchrony-proxy
2020-01-14 12:59:34,382 INFO [synchrony-interop-executor:thread-1] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] updateSynchronyConfiguration Synchrony External Service URL: http://0.0.0.0:8090/synchrony-proxy/v1
2020-01-14 12:59:34,382 INFO [synchrony-interop-executor:thread-1] [plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] updateSynchronyConfiguration Synchrony Internal Service URL: http://127.0.0.1:8091/synchrony/v1
2020-01-14 12:59:43,605 WARN [synchrony-interop-executor:thread-3] [plugins.synchrony.config.DefaultSynchronyConfigurationManager] enableSharedDrafts [Collab editing plugin] Enabling Shared Drafts 

Try to narrow down the issue by disabling the nginx proxy and access it using

localhost:8090

If it works without reverse proxy then the issue is the nginx. 

I changed the base-url to http://<ip>:8090 and removed the environment variables

CATALINA_CONNECTOR_PROXYNAME
CATALINA_CONNECTOR_PROXYPORT
CATALINA_CONNECTOR_SCHEME
CATALINA_CONNECTOR_SECURE

From the docker container and restarted it. Still the same issue, I cannot start Collaborative editing, it stays "off" and throws the exception. Could it be because this instance was already updated from several versions of confluence?

I actually just created a complete new container (with the same settings and same volumes) but that did not help as well. I suspect it is some configuration in confluence-cfg.xml or something.

I created a complete new confluence server with the data volume on an NFS share. Same issue. Then I created a new confluence server with a local data volume, then it works! Not sure yet what the issue is when the data is on an NFS share. I might also try an iSCSI share next to see if at least that works.

Bryan Bojorque Community Leader Jan 14, 2020

Hi @roman_baeriswyl ,

That is good to hear, so the issue is not application related hence infrastructure. In my test, it is a local volume.

As a final verdict, I gave up using Confluence on an NFS share. I moved my main instance locally and do regular backups to an NFS share.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

227 views 3 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you